Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-22-2013, 09:25 PM
jamull2852 jamull2852 is offline
Junior User
 
Join Date: Mar 2013
Posts: 58
jamull2852 is starting off with a positive reputation.
2007 Expedition problems HELPPPPP!!

My wife has a 2007 Expedition Limited with 126k miles on it. It started to shake around 40mph a few months ago and only seemed like it would happen when trying to go up a bridge or pass a car. I thought it might be the Coil over packs and took it to a mechanic and he tested it and it showed nothing. He changed the fuel filter and put a cleaner in the gas tank and it did feel better for a few weeks until the shaking started to come back. Well the check engine light came on and I tested it at autozone and it said Misfire cylinder #4. THen the light cleared. So now I dont know if its the sparkplug or the coil over pack. She just called me while Im at work and said as she was backing into the drive way it started to shake really bad and make a loud spudder noise but she said it was hard to explain the sound. I never felt or heard this while going to slow into a drive way. What could it be? its driving me crazy at work not knowing if the motor is shot or not.

Cliffs
-2007 expedition
-126k miles
-Shakes and spudders at 40mph when passing/going up hill
-engine light showing misfire on cylinder #4
- tonight it started to shake really bad and make a loud noise just backing into the drive way.
Reply With Quote
  #2  
Old 03-23-2013, 01:04 PM
expoman55 expoman55 is offline
Senior User
 
Join Date: May 2005
Location: upstate NY
Posts: 126
expoman55 is starting off with a positive reputation.
07 shudder

Don't know if it is the same 'shudder' so to speak however, that said, my 05 (115k miles) did the similar one day and threw a code for left bank timimg retard. End of the day was not timing phazers it was a broken chain guide. Stealer said $5k to fix and 60 hours of labor.. of course I signed right up NOT..... I went to my local mechanic.. 8 hours later, chainguide kit from Autozone $225. Repair was 600.00 YEP works like a charm.

All the best
Reply With Quote
  #3  
Old 03-23-2013, 03:56 PM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 236
jdm5630 is starting off with a positive reputation.
Have you ever changed the plugs? Does the CEL blink or just stay on?
Reply With Quote
  #4  
Old 03-23-2013, 10:27 PM
irishpride1 irishpride1 is offline
New User
 
Join Date: Oct 2011
Posts: 11
irishpride1 is starting off with a positive reputation.
change the cyl 4 coil pack.
Reply With Quote
  #5  
Old 03-23-2013, 10:40 PM
jamull2852 jamull2852 is offline
Junior User
 
Join Date: Mar 2013
Posts: 58
jamull2852 is starting off with a positive reputation.
I bought the truck with 60k miles and far as I know the plugs haven't been changed but I'm going to bring it to the mechanic this week for new plugs and all new coil packs. Hopefully this fixes it. The CEL came one one day and started blinking when my wife tried to pass going up hill and started to shake she said. I went to auto zone that day and pulled code misfire cylinder #4 p0304. After autozone the CEL has stayed off. Would it be smart to change all coil packs vs just one?
Reply With Quote
  #6  
Old 03-23-2013, 10:52 PM
jamull2852 jamull2852 is offline
Junior User
 
Join Date: Mar 2013
Posts: 58
jamull2852 is starting off with a positive reputation.
Is the spark plugs and coils I need to replace both?
My mechanic said the coils for the local autozone is around $40 for one!! Is this the same thing?

Reply With Quote
  #7  
Old 03-24-2013, 12:17 AM
5.4T's Avatar
5.4T 5.4T is offline
Elder User
 
Join Date: Mar 2011
Posts: 725
5.4T has a very good reputation on FTE.5.4T has a very good reputation on FTE.5.4T has a very good reputation on FTE.
jegs got a special for 25 $ per coil, I wish they had this deal when I did mines, I would have done it!!!!!!
JEGS Coil on Plug - JEGS
__________________
Reply With Quote
  #8  
Old 03-24-2013, 12:23 AM
jamull2852 jamull2852 is offline
Junior User
 
Join Date: Mar 2013
Posts: 58
jamull2852 is starting off with a positive reputation.
Would the ones I posted work? Or they aren't to reliable? I don't want to be changing them soon after changing them now. Motor craft is a good brand, correct?
Reply With Quote
  #9  
Old 03-24-2013, 01:46 AM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 236
jdm5630 is starting off with a positive reputation.
I would change plugs and coil packs. I had the same problem on my 07. It would shake while going uphill. Changed all sparks and it works fine now. Blinking CEL means misfire. Mine would also have a rough idle while in park
Reply With Quote
  #10  
Old 03-25-2013, 03:07 PM
jamull2852 jamull2852 is offline
Junior User
 
Join Date: Mar 2013
Posts: 58
jamull2852 is starting off with a positive reputation.
Just ordered the coil packs from jegs from the link above. Talked to my mechanic and he said we will start with the spark plugs and coils. Which plugs do you all recomend?
Reply With Quote
  #11  
Old 03-25-2013, 03:10 PM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 236
jdm5630 is starting off with a positive reputation.
Motorcraft
Reply With Quote
  #12  
Old 03-25-2013, 03:23 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Don't use any but the specified Motocraft plugs. Change coil and plug and report back.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #13  
Old 03-25-2013, 03:40 PM
jamull2852 jamull2852 is offline
Junior User
 
Join Date: Mar 2013
Posts: 58
jamull2852 is starting off with a positive reputation.
Is motor craft the oem brand?

And ill keep updating as I go and answer any questions. Thanks guys
Reply With Quote
  #14  
Old 03-25-2013, 03:47 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by jamull2852 View Post
Is motor craft the oem brand?

And ill keep updating as I go and answer any questions. Thanks guys
Yes, Motorcraft is Fords parts.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #15  
Old 03-26-2013, 01:17 AM
Wrench Turner CB Wrench Turner CB is offline
New User
 
Join Date: Jun 2009
Posts: 5
Wrench Turner CB is starting off with a positive reputation.
Any coil pack you buy other than motorcraft is a better COP. The problem in the factory coil over is the "potting"; thist is the stuff used to insulate the windings in the coil. I like using the Acel super coil you can pick up at Advance or Orellys. These are cheaper but last better than the motorcraft. BWD is also a good pick if you have a problem with the bright yellow Accel coil pack
Reply With Quote
Old 03-26-2013, 01:17 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Misfire in cylinder 5 (P0305) '06 Expedition EB 5.4 3v 83frankenstein250 Expedition & Navigator 10 06-07-2014 07:40 PM
2007 Expedition HELP jamull2852 Modular V8 (4.6L, 5.4L) 2 03-28-2013 10:43 AM
Ranger is dying... Shrink13 Ranger & B-Series 38 01-23-2011 03:55 PM
Need Help 99 Expedition PondScum Expedition & Navigator 21 01-26-2005 07:19 PM
Primary Battery Fuses IDF150Dude 1997 - 2003 F150 2 01-17-2005 09:05 AM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 08:08 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup