Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-09-2013, 12:23 PM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 236
jdm5630 is starting off with a positive reputation.
changed the spark plugs. now i smell gas

i changed the sparks in my 07 expy about 2 weeks ago and i was changing the oil today so when i was starting the engine up. i smelled gas coming from the engine. goes away after about 10 seconds what could it be?
Reply With Quote
  #2  
Old 03-09-2013, 04:15 PM
5.4T's Avatar
5.4T 5.4T is offline
Elder User
 
Join Date: Mar 2011
Posts: 725
5.4T has a very good reputation on FTE.5.4T has a very good reputation on FTE.5.4T has a very good reputation on FTE.
was it cold? could be a loose sparkplug. If i was you i would check it out.....
__________________
Reply With Quote
  #3  
Old 03-09-2013, 04:57 PM
JWC 3's Avatar
JWC 3 JWC 3 is offline
Post Fiend
 
Join Date: Dec 2012
Location: Tennessee
Posts: 6,651
JWC 3 has a superb reputationJWC 3 has a superb reputationJWC 3 has a superb reputationJWC 3 has a superb reputationJWC 3 has a superb reputationJWC 3 has a superb reputationJWC 3 has a superb reputationJWC 3 has a superb reputationJWC 3 has a superb reputationJWC 3 has a superb reputationJWC 3 has a superb reputation
When changing the plugs , did you move the injectors in their seat ? Maybe an injector o ring is seeping . Just a thought .
__________________
78 F100 ,Daily driver . Life will test you . Never give up ....
Reply With Quote
  #4  
Old 03-10-2013, 03:34 AM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 236
jdm5630 is starting off with a positive reputation.
Checked the spark plugs and #8 was loose. Tightened it and smell seems to have gone away
Reply With Quote
Old 03-10-2013, 03:34 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
gas smell on startup jdm5630 2007 - 2014 Expedition & Navigator 1 06-27-2013 02:01 AM
05 Spark Plug - Gas Smell questions CelticDevilDog 2004 - 2008 F150 3 08-13-2012 09:59 AM
exhaust or gas smell JAMES GREGORY Expedition & Navigator 1 12-21-2011 05:50 PM
oil smells like gas pcjordan82 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 30 08-20-2009 01:29 AM
94 302 Wont start HELP!?!?! RIMZ24 1987 - 1996 F150 & Larger F-Series Trucks 5 12-05-2005 11:05 AM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 12:09 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup