Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-09-2013, 11:23 AM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 225
jdm5630 is starting off with a positive reputation.
changed the spark plugs. now i smell gas

i changed the sparks in my 07 expy about 2 weeks ago and i was changing the oil today so when i was starting the engine up. i smelled gas coming from the engine. goes away after about 10 seconds what could it be?
Reply With Quote
  #2  
Old 03-09-2013, 03:15 PM
5.4T's Avatar
5.4T 5.4T is offline
Elder User
 
Join Date: Mar 2011
Posts: 721
5.4T has a good reputation on FTE.5.4T has a good reputation on FTE.5.4T has a good reputation on FTE.
was it cold? could be a loose sparkplug. If i was you i would check it out.....
__________________
Reply With Quote
  #3  
Old 03-09-2013, 03:57 PM
JWC 3's Avatar
JWC 3 JWC 3 is offline
Post Fiend
 
Join Date: Dec 2012
Location: Tennessee
Posts: 5,968
JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.
When changing the plugs , did you move the injectors in their seat ? Maybe an injector o ring is seeping . Just a thought .
__________________
78 F100 ,Daily driver . Life will test you . Never give up ....
Reply With Quote
  #4  
Old 03-10-2013, 01:34 AM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 225
jdm5630 is starting off with a positive reputation.
Checked the spark plugs and #8 was loose. Tightened it and smell seems to have gone away
Reply With Quote
Old 03-10-2013, 01:34 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine oil smells like gas kyle.h Big Block V8 - 385 Series (6.1/370, 7.0/429, 7.5/460) 3 12-30-2013 01:22 PM
2006 F150 COP smells of burnt oil? rchill84 2004 - 2008 F150 0 12-27-2013 05:02 AM
gas smell on startup jdm5630 2007+ Expedition & Navigator 1 06-27-2013 01:01 AM
2004 Explorer flooding? bigdan1979f-250 Explorer, Sport Trac, Mountaineer & Aviator 1 02-25-2013 12:09 PM
05 Spark Plug - Gas Smell questions CelticDevilDog 2004 - 2008 F150 3 08-13-2012 08:59 AM



All times are GMT -5. The time now is 02:37 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup