Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator




 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 03-06-2013, 07:36 PM
Jaylegger Jaylegger is offline
New User
Garage is empty, add now
 
Join Date: Nov 2011
Posts: 7
Jaylegger is starting off with a positive reputation.
2007 Navigator power liftgate and power latch not working

Hi everyone, I need some thoughts on my liftgate issue that began today. I opened the gate normally, the latch whirred (unlocked ) when I pulled he lever and the gate opened, I then shut it but it wouldn't latch, the latch mechanism will not stay in closed position nor is there any electrical noise to indicate it's even trying. I then checked the power liftgate and nothing works there either, not via the button inside the gate, the console button, or the remote.

The latch mechansim itself moves freely from the open to closed positon but won't click lock closed.

I've checked and test for continuity all appropriate fuses inside the vehicle and engine compartment and they are fine. Regardless I essentially have lost power to both the latch and the powerlift which are two different circuits. I'll be checking connector C4339 in the tailgate tomorrow but in the meantime does anyone have any thoughts as to what may be causing this?

Thanks.
Reply With Quote
  #2 (permalink)  
Old 03-10-2013, 09:44 PM
Jaylegger Jaylegger is offline
New User
Garage is empty, add now
 
Join Date: Nov 2011
Posts: 7
Jaylegger is starting off with a positive reputation.
Problem somehow fixed itself, all is good.
Reply With Quote
Old 03-10-2013, 09:44 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 09:16 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.



 
vbulletin Admin Backup