Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Southwest Region > New Mexico Chapter
Sign in using an external account
Register Forgot Password?


New Mexico Chapter Join Chapter, Leader: CelticDevilDog

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 02-25-2013, 11:49 AM
CM-7.3PSD's Avatar
CM-7.3PSD CM-7.3PSD is offline
Freshman User
 
Join Date: Feb 2013
Posts: 29
CM-7.3PSD is starting off with a positive reputation.
Anyone with A.E./7.3 knowledge in southern New Mexico?

I am in need of a scan and perhaps a hand. i think i have some power issues. any help would be great thank you.

06/99 f250 7.3 psd 6spd manual 2wd 180,000m bone stock...
Reply With Quote
  #2 (permalink)  
Old 02-26-2013, 10:51 AM
ztodd377's Avatar
ztodd377 ztodd377 is offline
of FTE, RHN, and BEER!
 
Join Date: Mar 2007
Location: Albuquerque
Posts: 567
ztodd377 is gaining momentum as a positive member of FTE.ztodd377 is gaining momentum as a positive member of FTE.
Where are you located! I'm in ABQ.
Reply With Quote
  #3 (permalink)  
Old 02-26-2013, 12:42 PM
CM-7.3PSD's Avatar
CM-7.3PSD CM-7.3PSD is offline
Freshman User
 
Join Date: Feb 2013
Posts: 29
CM-7.3PSD is starting off with a positive reputation.
Quote:
Originally Posted by ztodd377 View Post
Where are you located! I'm in ABQ.
Im in las cruces. sorry i didnt post that in the first place. oops
Reply With Quote
  #4 (permalink)  
Old 02-26-2013, 06:42 PM
ztodd377's Avatar
ztodd377 ztodd377 is offline
of FTE, RHN, and BEER!
 
Join Date: Mar 2007
Location: Albuquerque
Posts: 567
ztodd377 is gaining momentum as a positive member of FTE.ztodd377 is gaining momentum as a positive member of FTE.
What kind of symptoms are you having? And have you done any troubleshooting yet?
__________________
'01 F250 XLT 4x4 x-cab lb; 6637 w/ Pete's Cover; GTP38R; DP Tuner (stock, Hi-idle, 60T, 80E, 120R); ISSPRO boost, EGT, trans; bellowed up-pipes; 4" exhaust; muffler delete; 50 cent; HPX; Tugger kit w/ Sonnax .427 valve; Harpoon; Mag-Hytec diff covers; 2 1/2" lift front & rear; DBA 4000 Slotted Rotors w/ Hawk LTS pads; Firestone bags & compressor.
Reply With Quote
  #5 (permalink)  
Old 03-01-2013, 10:07 AM
CM-7.3PSD's Avatar
CM-7.3PSD CM-7.3PSD is offline
Freshman User
 
Join Date: Feb 2013
Posts: 29
CM-7.3PSD is starting off with a positive reputation.
Quote:
Originally Posted by ztodd377 View Post
What kind of symptoms are you having? And have you done any troubleshooting yet?
I bought the truck a year ago an it had 130,000m and absolutely no issues. Previous owner took very exellent care of truck was like new inside an out. I drive back an forth from la crues to north dakota and its my work tuck in ND too. I stay on top of all fluid/filter changes. It was extremely difficult to start this winter- even when like 40 put. replaced gpr and switched to t6 5w40 and all was well. during that i noticed what appears to be exhaust gas in the top of my degas. Nothing seems to be mixing woth the coolant though- just the top of the bottle. She also has lost the resonsivness it once had. like the truck is tired and wont stand up like it used to? I also have a small coolant leak coming from the thermo housing and lower hose. whole engine bay was etting oily an dusty all the way off the tranny and starter so i cleaned her up till almost spotless and found no other leaks so far. I took it to a local diesel performane shop an they said the truck is actually pretty healthy and everythig is running to specs includig injectors an turbo. they also sai the grime in my degas was casting sand and a good flush and coolant filter would solve it. I still think something else is going on as i drive the truck aall the time and it doesnt feel the same. It has fresh oil/filter and new fuel an air filter.
Reply With Quote
  #6 (permalink)  
Old 03-01-2013, 10:25 AM
CM-7.3PSD's Avatar
CM-7.3PSD CM-7.3PSD is offline
Freshman User
 
Join Date: Feb 2013
Posts: 29
CM-7.3PSD is starting off with a positive reputation.
This is my first diesel so im learnig as i go. Literally ALL my tools are in ND so troublshooting/working on the truck has been difficult. i have heard good thigs about AE and wanted to see what it reads for my truck. maybe to get an idea where to direct the limted funds i have. I really need to get back to work! I work in construction and haul people tools and materials 14hrs a day 7days a week plus the many cross country journeys. sorry for the lengthy post but im told you get better help that way.
Reply With Quote
  #7 (permalink)  
Old 03-01-2013, 12:12 PM
ztodd377's Avatar
ztodd377 ztodd377 is offline
of FTE, RHN, and BEER!
 
Join Date: Mar 2007
Location: Albuquerque
Posts: 567
ztodd377 is gaining momentum as a positive member of FTE.ztodd377 is gaining momentum as a positive member of FTE.
Good post. My buddy right around the corner here is getting ready to purchase AE with his tax return but doesn't have it yet. As for the coolant leak, I had one like that and when I replaced my thermostat I put thermostat safe gasket maker on there and it solved the problem. I can also speak to the coolant filter. My truck had around 136,000 when I put my coolant filter system on, and on the first filter change I cut the filter open to see how much junk was in there. There was a ton of casting sand in there. It's gotten less and less over time with the filter changes and I even swapped over to the extended life coolant (500,000 mile change out). A lot of guys here have done that.
Not too sure about the power loss yet.
Reply With Quote
  #8 (permalink)  
Old 03-01-2013, 12:55 PM
CM-7.3PSD's Avatar
CM-7.3PSD CM-7.3PSD is offline
Freshman User
 
Join Date: Feb 2013
Posts: 29
CM-7.3PSD is starting off with a positive reputation.
Elc, a filter, ccvmod, intake, exhaust, etc will be done before too long to help minimize future issues. Im hoping to prevent spending money on things i dont need to. i hope. I have realized this truck is gonna cost me some coin to get it where i want it, but should last a loooong time after that. Thought about selling it and the diesel tech told me im nuts haha. good to know...
__________________
"Lurch" 06/99 F250 XLT 7.3 PSD 6spd manual 2wd, 180000 miles, bone stock- but not for long!
Reply With Quote
  #9 (permalink)  
Old 03-01-2013, 05:04 PM
ztodd377's Avatar
ztodd377 ztodd377 is offline
of FTE, RHN, and BEER!
 
Join Date: Mar 2007
Location: Albuquerque
Posts: 567
ztodd377 is gaining momentum as a positive member of FTE.ztodd377 is gaining momentum as a positive member of FTE.
And if you're ever up in ABQ I got tools and a place to work on stuff if needed.
Reply With Quote
  #10 (permalink)  
Old 03-01-2013, 06:28 PM
CM-7.3PSD's Avatar
CM-7.3PSD CM-7.3PSD is offline
Freshman User
 
Join Date: Feb 2013
Posts: 29
CM-7.3PSD is starting off with a positive reputation.
Man i really appreciate the offer. its no fun at my place- no garage/shop and nothing but dust and sand.
__________________
"Lurch" 06/99 F250 XLT 7.3 PSD 6spd manual 2wd, 180000 miles, bone stock- but not for long!
Reply With Quote
  #11 (permalink)  
Old 03-01-2013, 09:27 PM
ztodd377's Avatar
ztodd377 ztodd377 is offline
of FTE, RHN, and BEER!
 
Join Date: Mar 2007
Location: Albuquerque
Posts: 567
ztodd377 is gaining momentum as a positive member of FTE.ztodd377 is gaining momentum as a positive member of FTE.
Anytime you're up this way. Here's my cell 907-301-7347. My buddy Matt (HH60FE on FTE) lives nearby and has a 7.3 also.

Todd
Reply With Quote
  #12 (permalink)  
Old 03-09-2013, 12:59 PM
tdpower's Avatar
tdpower tdpower is offline
Postmaster
 
Join Date: Dec 2008
Posts: 3,274
tdpower is a splendid one to beholdtdpower is a splendid one to beholdtdpower is a splendid one to beholdtdpower is a splendid one to beholdtdpower is a splendid one to beholdtdpower is a splendid one to beholdtdpower is a splendid one to behold
Quote:
Originally Posted by CM-7.3PSD View Post
I bought the truck a year ago an it had 130,000m and absolutely no issues. Previous owner took very exellent care of truck was like new inside an out. I drive back an forth from la crues to north dakota and its my work tuck in ND too. I stay on top of all fluid/filter changes. It was extremely difficult to start this winter- even when like 40 put. replaced gpr and switched to t6 5w40 and all was well. during that i noticed what appears to be exhaust gas in the top of my degas. Nothing seems to be mixing woth the coolant though- just the top of the bottle. She also has lost the resonsivness it once had. like the truck is tired and wont stand up like it used to? I also have a small coolant leak coming from the thermo housing and lower hose. whole engine bay was etting oily an dusty all the way off the tranny and starter so i cleaned her up till almost spotless and found no other leaks so far. I took it to a local diesel performane shop an they said the truck is actually pretty healthy and everythig is running to specs includig injectors an turbo. they also sai the grime in my degas was casting sand and a good flush and coolant filter would solve it. I still think something else is going on as i drive the truck aall the time and it doesnt feel the same. It has fresh oil/filter and new fuel an air filter.

Tugly was having a similar problem with exhaust gasses in the coolant. Looks like it was a cracked injector cup. You might want to shoot him a pm or start a new thread in the 7.3 section.

Here is a link to his thread: http://www.ford-trucks.com/forums/12...-stick-up.html
Reply With Quote
  #13 (permalink)  
Old 03-09-2013, 01:28 PM
CM-7.3PSD's Avatar
CM-7.3PSD CM-7.3PSD is offline
Freshman User
 
Join Date: Feb 2013
Posts: 29
CM-7.3PSD is starting off with a positive reputation.
Quote:
Originally Posted by tdpower View Post
Tugly was having a similar problem with exhaust gasses in the coolant. Looks like it was a cracked injector cup. You might want to shoot him a pm or start a new thread in the 7.3 section.

Here is a link to his thread: http://www.ford-trucks.com/forums/12...-stick-up.html
Yeah Tugly got me to the exhaust/coolant conclusion in a diff thread i started specifically for that. Those will be replaced when i upgrade the injectors at a later date. im gonna let her sit till i can do it right. i just want to run AE to learn about my truck as much as possible before i go sinking whole loaves of bread into it haha.
__________________
"Lurch" 06/99 F250 XLT 7.3 PSD 6spd manual 2wd, 180000 miles, bone stock- but not for long!
Reply With Quote
Old 03-09-2013, 01:28 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Regional Chapters > Southwest Region > New Mexico Chapter

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELLO EVERYONE?!?! dragoon1101 New Member Introductions 1 06-23-2014 10:46 AM
Getting out of the heat bigb56 1999 - 2003 7.3L Power Stroke Diesel 3 06-12-2014 10:30 PM
White smoke on deceleration jac3i 1999 - 2003 7.3L Power Stroke Diesel 2 05-26-2014 10:37 PM
Buying used, need advice Deep South 1999 - 2003 7.3L Power Stroke Diesel 5 07-10-2013 09:10 PM
Anyone with A.E./7.3 knowledge in southern New Mexico? CM-7.3PSD 1999 - 2003 7.3L Power Stroke Diesel 12 03-04-2013 01:26 PM



All times are GMT -5. The time now is 02:07 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup