Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-22-2013, 10:29 PM
Crovax's Avatar
Crovax Crovax is offline
New User
 
Join Date: Mar 2006
Location: San Antonio, Texas
Posts: 7
Crovax is starting off with a positive reputation.
Downshift Clunk

I have a 2008 Expedition (68k miles) with towing package that likes to clunk, going uphill, right before it downshifts from 6th to 4th. It's a double clunk right before it downshifts. RPM is anywhere between 1100 to 1500, mph doesn't matter. Cruise on or off, I have same problem.Definitely feels like it's coming from the rear of the truck.

Checked the transmission fluid level and it's fine. Haven't checked the drive shaft for play yet. What am I looking at here?
Reply With Quote
  #2  
Old 02-25-2013, 10:48 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Take it in to the dealer. The tranny might need to be reflashed. There were many software issues with these.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3  
Old 05-04-2013, 01:10 AM
Crovax's Avatar
Crovax Crovax is offline
New User
 
Join Date: Mar 2006
Location: San Antonio, Texas
Posts: 7
Crovax is starting off with a positive reputation.
Ended up being 2 bad plugs with cracked porcelain. Number 8 plug decided half of it would stay behind.
Reply With Quote
  #4  
Old 05-04-2013, 08:14 AM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 227
jdm5630 is starting off with a positive reputation.
you should already change the rest of the plugs since you replaced 2
Reply With Quote
  #5  
Old 05-04-2013, 12:15 PM
Crovax's Avatar
Crovax Crovax is offline
New User
 
Join Date: Mar 2006
Location: San Antonio, Texas
Posts: 7
Crovax is starting off with a positive reputation.
I did all 8 at the same time.
Reply With Quote
  #6  
Old 05-04-2013, 01:13 PM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 227
jdm5630 is starting off with a positive reputation.
oh im sorry i must have read it wrong
Reply With Quote
Old 05-04-2013, 01:13 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
4R75E transmission abyars111 Clutch, Transmission, Differential, Axle & Transfer Case 1 07-16-2014 01:19 PM
2007 Sport Trac traction control problems catman900 Explorer, Sport Trac, Mountaineer & Aviator 2 11-02-2013 08:18 PM
'09 4th gear intermittent slip 88K miles galaxie641 2009+ F150 3 10-27-2013 01:39 PM
"Clunk" While Accelerating and Braking mayorphill Super Duty & Heavy Duty 23 05-06-2013 07:23 PM
2002 Ford Explorer transmission intermitent clunks RRousta Explorer, Sport Trac, Mountaineer & Aviator 4 02-07-2013 03:07 PM



All times are GMT -5. The time now is 09:14 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup