07 Expi one drl - Ford Truck Enthusiasts Forums
 

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Log In 


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

07 Expi one drl

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-18-2013, 09:04 PM
mech1's Avatar
mech1 mech1 is offline
Senior User
 
Join Date: Sep 2001
Posts: 170
mech1 is starting off with a positive reputation.
07 Expi one drl

it has the drl enabled. problem is start the truck no drl, put in gear they either both go on and then when you switch from rev to drive the right one goes out, or when going from park to any gear the right one blips on for the briefest of seconds then stays out. it has autolamps and everything else works fine high beams low beams both bulbs work, new bulbs in it too, any help appreciated, am thinking drl module? where is it, or is there a resistor for each lamp i have done some reading into it here and seems there is a plug in box for each side somewhere behind the housings? thanks!!!
Reply With Quote
  #2  
Old 06-05-2013, 11:06 PM
mech1's Avatar
mech1 mech1 is offline
Senior User
 
Join Date: Sep 2001
Posts: 170
mech1 is starting off with a positive reputation.
ok when customer came in I jokingly asked him where he got his headlight bulb, guess what off the shelf local parts store bulb caused the whole problem!! I hate these micro managing vehicles lol
Reply With Quote
Old 06-05-2013, 11:06 PM
 
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 F-150 V8 XLT SuperCrew - LED Lights Installed, having electrical issues BrdNV82 2009 - 2014 F150 3 05-24-2015 05:28 PM
2013 Escape kordyf Escape & Escape Hybrid 0 12-07-2013 05:28 PM
My little DIY LED DRL mod AzPatMan Excursion - King of SUVs 85 08-02-2013 02:33 AM
Headlight Wiring Diagram 02 F250 w/DRL thomabb Electrical Systems/Wiring 8 04-29-2010 09:23 AM
97 F350 DRL Module location joyedco Electrical Systems/Wiring 5 10-06-2003 05:28 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 03:29 PM.

 

Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup