Go Back   Ford Truck Enthusiasts Forums > Older, Classic & Antique Trucks > 1957 - 1960 F100 & Larger F-Series Trucks
Sign in using an external account
Register Forgot Password?


1957 - 1960 F100 & Larger F-Series Trucks Discuss the Box Style Ford Trucks

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-09-2013, 09:35 PM
manlikesford manlikesford is offline
Junior User
 
Join Date: Jan 2001
Location: Puyallup, WA USA
Posts: 59
manlikesford is starting off with a positive reputation.
Crappy transmission mount?

I have a 1960 F100 on a f250 chasis I bought last year and am starting to tear apart. The person before me put in a 390 with a c6 tranny I believe it is. After taking things apart, I see he welded on a mount on to the frame and I think it looks like crap. Thinking of getting a mount through one of the truck suppliers I found for about $50 that bolts in and looks cleaner. Wonder what the greater minds out there think. I am trying to upload pictures for view through imageshack and hope it works. I have tried to create a album in the gallery through ford-trucks website, but it won't upload my pics. It says it did, but nothing shows up. Thanks in advance for any insight or info.

[img=http://imageshack.us/scaled/thumb/443/1000596c.jpg]
[img=http://imageshack.us/scaled/thumb/834/1000627eb.jpg]
[img=http://imageshack.us/scaled/thumb/801/1000590x.jpg]
[img=http://imageshack.us/scaled/thumb/716/1000548n.jpg]
Reply With Quote
  #2  
Old 01-10-2013, 10:55 AM
hiball3985's Avatar
hiball3985 hiball3985 is offline
Posting Guru
 
Join Date: Mar 2005
Location: tujunga, calif
Posts: 1,897
hiball3985 is gaining momentum as a positive member of FTE.
That's a no brainier , cut that crap off and use one of the bolt in ones
__________________
JIM
1960 F100 Panel 223 3 spd overdrive

1966 F250 390 4 spd

1957 Ranchero 292 3 spd T85 overdrive
Reply With Quote
Old 01-10-2013, 10:55 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Older, Classic & Antique Trucks > 1957 - 1960 F100 & Larger F-Series Trucks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
first ae usage jps47 1999 - 2003 7.3L Power Stroke Diesel 2 11-10-2013 05:16 PM
Removable winch henritrinelli 1978 - 1996 Big Bronco 26 07-24-2013 05:03 AM
96 Powerstroke F250KingPin 1994.5 - 1997 7.3L Power Stroke Diesel 5 02-19-2013 11:02 PM
f100 i got few weeks ago gmill09 1973 - 1979 F-100 & Larger F-Series Trucks 9 12-30-2012 11:05 PM
My first rock trip henritrinelli 1978 - 1996 Big Bronco 9 06-30-2012 09:04 PM



All times are GMT -5. The time now is 06:50 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup