Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Ford V6 > 3.0L V6
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-08-2013, 11:37 PM
Klindsey1990 Klindsey1990 is offline
New User
 
Join Date: Jan 2013
Posts: 3
Klindsey1990 is starting off with a positive reputation.
2000 Ford Ranger 3.0 v6 missing

Hi folks, I'm new to this so forgive me if I don't give enough info. I've been having problems with my Ranger misfiring. It had blown the headgasket about a year and a half ago and I had it replaced. I now have around 126,000 miles on it and just before Christmas it started developing a miss. I put fuel injector cleaner in it, which seemed to help slightly but it came right back as I was driving home that night. It blew the number 3 plug out of the motor the next day, never had that happen before, ha. Anyway, me and my dad have changed plugs, plug wires, and coil pack, still the same problem. I don't want to keep pouring money into it and it doesn't fix the problem. It misses at an idle and the motor shakes. It runs, and it misses from the 50-65 mph range. If anyone has had this problem or ideas I would greatly appreciate it. Thanks!
Reply With Quote
  #2  
Old 01-09-2013, 12:52 AM
JWC 3's Avatar
JWC 3 JWC 3 is online now
Post Fiend
 
Join Date: Dec 2012
Location: Tennessee
Posts: 6,603
JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.
Do you have any codes ? try to narrow it down to the missing cyl. Ck for proper fire , bad injector , burnt valve ,wiring issue ,ect . Do a compresson test to ck . cyl. health .
Reply With Quote
  #3  
Old 01-15-2013, 02:28 PM
Klindsey1990 Klindsey1990 is offline
New User
 
Join Date: Jan 2013
Posts: 3
Klindsey1990 is starting off with a positive reputation.
Quote:
Originally Posted by JWC 3 View Post
Do you have any codes ? try to narrow it down to the missing cyl. Ck for proper fire , bad injector , burnt valve ,wiring issue ,ect . Do a compresson test to ck . cyl. health .

I had a diagnostic check on it today. Cylinder 3 and 5 were misfiring along with throttle control sensor bad. Replaced sensor and had computer reset. I've changed the plugs and wires about 6 months ago. Maybe got a bad set of plugs or wires??
Reply With Quote
  #4  
Old 01-15-2013, 08:22 PM
JWC 3's Avatar
JWC 3 JWC 3 is online now
Post Fiend
 
Join Date: Dec 2012
Location: Tennessee
Posts: 6,603
JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.
Do you still have the miss ? if you only changed the tps , you probably do . Ck #3 and #5 plug . Also ck coil , plugs, and wires for carbon tracking . It does have one coil ,I think . #3 and #5 paired ? one can cause a code for both . Ck coil for cracks . Cracks will leak voltage and cause misfire . If not ignition look at fuel and compression .
Reply With Quote
  #5  
Old 01-16-2013, 02:38 PM
Klindsey1990 Klindsey1990 is offline
New User
 
Join Date: Jan 2013
Posts: 3
Klindsey1990 is starting off with a positive reputation.
Got the miss. changed 3 and 5 plugs and wires. So far so good.
Reply With Quote
  #6  
Old 01-16-2013, 07:08 PM
JWC 3's Avatar
JWC 3 JWC 3 is online now
Post Fiend
 
Join Date: Dec 2012
Location: Tennessee
Posts: 6,603
JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.JWC 3 has a spectacular reputation.
Good luck , hope you got it !
Reply With Quote
Old 01-16-2013, 07:08 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
95 Ranger 2.3 L low speed acceleration miss and hesitation perryg114 Ranger & B-Series 13 05-09-2014 10:02 AM
Engine misses for a few mins at cold start up. rlmtowing 1973 - 1979 F-100 & Larger F-Series Trucks 7 02-16-2009 10:35 PM
98 Explorer 5.0 - Engine missing but no CEL crandolph Explorer, Sport Trac, Mountaineer & Aviator 5 03-16-2005 07:11 PM
'91 Ranger XLT 2.3 L 4 cyl ginna Ranger & B-Series 2 01-04-2004 09:39 PM
misses when cold bigby 1967 - 1972 F-100 & Larger F-Series Trucks 5 11-30-2003 11:11 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Ford V6 > 3.0L V6

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 01:34 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup