Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator




 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 01-04-2013, 12:11 PM
GSDSROK GSDSROK is offline
New User
Garage is empty, add now
 
Join Date: Jan 2013
Posts: 11
GSDSROK is starting off with a positive reputation.
'13 Navi, aftermarket exhaust

I have a 13 Navi. Have always put on Borla exhausts but they and others do not seem to have aftermarket bolt on cat-back systems for Expeditions or Navigators. Does anyone have any experience installing systems, what did you install and how did it work out?

Jeff M
Reply With Quote
  #2 (permalink)  
Old 01-05-2013, 06:47 AM
eddiemoney eddiemoney is offline
Senior User
Garage is empty, add now
 
Join Date: Jun 2009
Posts: 274
eddiemoney is starting off with a positive reputation.
I have seen magna and gibson....I'd always go magna - hands down
Reply With Quote
  #3 (permalink)  
Old 01-05-2013, 08:35 AM
GSDSROK GSDSROK is offline
New User
Garage is empty, add now
 
Join Date: Jan 2013
Posts: 11
GSDSROK is starting off with a positive reputation.
Thanks, not sure why It did not come up on my first query.
Reply With Quote
  #4 (permalink)  
Old 01-07-2013, 03:26 PM
johnkn johnkn is offline
Senior User
Garage is empty, add now
 
Join Date: Aug 2009
Posts: 158
johnkn is gaining momentum as a positive member of FTE.
I had a Magnaflow 3" mandrel cat back system on my Expedition and cut the muffler out after 2 weeks. In the large rectangular volumn of the Extedition the drone was terrible. I've driven them on an F150 and it was fine. First time in my 57 years that I couldn't live with an exhaust system and I have Flowmasters, Spintechs, old Thrush glass packs, Corsa, straight pipes on my bikes, etc. Replaced the muffler with a Stainless Works and works much better. I have Stainless Works also on one of my BOSS cars.
Reply With Quote
  #5 (permalink)  
Old 01-07-2013, 08:27 PM
GSDSROK GSDSROK is offline
New User
Garage is empty, add now
 
Join Date: Jan 2013
Posts: 11
GSDSROK is starting off with a positive reputation.
Interesting, I had a 97 Expedition and had a Borla installed. After a few months I was fed up with the 'drone' and called them. They had a new style they swapped out for no charge. The new one had the coffee can sized second muffler near the tailpipe and it was much better. The one I had on my 2000 Navigator had the second muffler and was just fine except when I was pulling my trailer up a mountain pass . My 13 Navigator has the weirdest thing I have ever seen on an exhaust system. It is a plastic round plastic gadget hanging off the exhaust pipe just in front of the muffler. It is light brown, plasic, about 3" long and 2" in diameter. I can't imagine what it is for. No wires, tubing and a hole in it covered by what feels like a rubber plug.
Reply With Quote
  #6 (permalink)  
Old 01-07-2013, 09:38 PM
johnkn johnkn is offline
Senior User
Garage is empty, add now
 
Join Date: Aug 2009
Posts: 158
johnkn is gaining momentum as a positive member of FTE.
I beleive the device hanging off your stock exhaust is meant to lessen the harmonics of the stock exhaust system. A number of new and older cars use them. Good luck...
Reply With Quote
  #7 (permalink)  
Old 01-08-2013, 02:01 PM
svfetter svfetter is offline
Freshman User
Garage is empty, add now
 
Join Date: Oct 2012
Posts: 29
svfetter is starting off with a positive reputation.
I have used Gibson and been very happy with them. One on a 2000 Expedition and recently installed on my 2011 Expedition. Sound was great on the 2000 as it had dual outlets. No Drone. Much quieter on the 2011 due to dual outlets not being available due to not enough space. Relatively easy install in the drive way. My 2011 system is all 304 SS. No Worries.
Reply With Quote
  #8 (permalink)  
Old 01-10-2013, 07:18 PM
rayofsi rayofsi is offline
Junior User
Garage is empty, add now
 
Join Date: Dec 2011
Location: New York City
Posts: 61
rayofsi is starting off with a positive reputation.
Quote:
Originally Posted by svfetter View Post
I have used Gibson and been very happy with them. One on a 2000 Expedition and recently installed on my 2011 Expedition. Sound was great on the 2000 as it had dual outlets. No Drone. Much quieter on the 2011 due to dual outlets not being available due to not enough space. Relatively easy install in the drive way. My 2011 system is all 304 SS. No Worries.
hi was the 2011 install a easy diy job? i have the gibson kit in my garage since last year!
__________________
2011 Ford Expedition XLT
2x German Cars not worth Mentioning
Reply With Quote
  #9 (permalink)  
Old 01-11-2013, 07:13 AM
svfetter svfetter is offline
Freshman User
Garage is empty, add now
 
Join Date: Oct 2012
Posts: 29
svfetter is starting off with a positive reputation.
Quote:
Originally Posted by rayofsi View Post
hi was the 2011 install a easy diy job? i have the gibson kit in my garage since last year!
Yes, I consider the install to be real simple. You will need some ramps to roll the rear up on. Then you will need to cut the old system at the axle to get it out. Replace with the new and line everything up. Then tighten. Not quote as much sound as I would like but the way this truck is set up with the 6 speed trans vs my 2000 has a lot to do with that as well. Good Luck!
Reply With Quote
  #10 (permalink)  
Old 01-16-2013, 04:35 AM
Mario.Pe. Mario.Pe. is offline
New User
Garage is empty, add now
 
Join Date: Jul 2012
Posts: 3
Mario.Pe. is starting off with a positive reputation.
Hey

I have a Flowmaster super 44 on my Expedition EL and love it. First I had the magnaflow cat-back exhaust but it wasn't much louder as the stock exhaust. If you don't want to make the exhaust by yourself with a Flowmaster 44 I would buy the CGS cat back exhaust. It sounds nearly like the Flowmaster sounds.
2007 - 2012 Ford Expedition Cat-Back Exhaust 60047 - CGS Motorsports 2007 2008 2009 2010 2011 2012


Greetings from Germany
Reply With Quote
Old 01-16-2013, 04:35 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 01:27 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.



 
vbulletin Admin Backup