Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator




 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 12-22-2012, 04:47 PM
billfumick billfumick is offline
New User
Garage is empty, add now
 
Join Date: Feb 2010
Posts: 17
billfumick is starting off with a positive reputation.
Navigator Frozen Power Liftgate

Hello...
We have a 2008 Navigator and live in Vermont.
The Rear Power Liftgate CONSTANTLY freezes from the cold weather.
When we bring the car to our local dealer they let it sit inside and "defrost".
Then they have the ***** to tell us NOTHING IS WRONG WITH IT!
Has anyone experienced the same thing? Is there a trick to get it open?
Thanks!
Reply With Quote
  #2 (permalink)  
Old 12-27-2012, 12:00 AM
johnkn johnkn is offline
Senior User
Garage is empty, add now
 
Join Date: Aug 2009
Posts: 158
johnkn is gaining momentum as a positive member of FTE.
Try spraying the lift gate gasget with silicon spray and make sure the TOP of the lift gate is completely clear of ice and snow. And if you can, park where the sun warms the back end in the morning.
Reply With Quote
  #3 (permalink)  
Old 12-27-2012, 12:14 AM
billfumick billfumick is offline
New User
Garage is empty, add now
 
Join Date: Feb 2010
Posts: 17
billfumick is starting off with a positive reputation.
Thanks John,
Definitely not the gasket... Its like the "latch" if frozen in the locked position...
I tried pulling pretty hard... The liftgate just wont budge....
Its been frozen shut for a week now... So Anoying!!
Reply With Quote
  #4 (permalink)  
Old 12-27-2012, 12:39 AM
johnkn johnkn is offline
Senior User
Garage is empty, add now
 
Join Date: Aug 2009
Posts: 158
johnkn is gaining momentum as a positive member of FTE.
So, this is my experience from Sunday at a hotel (4 days ago). Tailgate was frozen shut, lift gate would not lift 10x over 45 minutes. Lift gate handle didn't feel "right" like it was after the first pull. I pulled the vehicle so the back end was in the sun. And after another30 minutes it finally opened. Think it was the ice at the top rather than bottom. Silicon will help.good luck
Reply With Quote
  #5 (permalink)  
Old 12-27-2012, 08:04 AM
billfumick billfumick is offline
New User
Garage is empty, add now
 
Join Date: Feb 2010
Posts: 17
billfumick is starting off with a positive reputation.
Thanks, John!
I'll give it a try!
Reply With Quote
Old 12-27-2012, 08:04 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 09:20 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.



 
vbulletin Admin Backup