Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-16-2012, 06:45 PM
tbe2002 tbe2002 is offline
New User
 
Join Date: Feb 2010
Posts: 6
tbe2002 is starting off with a positive reputation.
08 expy limited wiper on all the time

Hey guys I need some help here. I having issues where my front wipers and sprayers come one a min after the truck starts up. This just started last week. Came home looked at the truck and noticed that the wipers were in the up position on the windshield. Went to look at it. Battery was dead. used my jumper box and started the truck and a min later the wipers and sprayers came on and wouldn't go off.

I decided id replace the battery with a new Motorcraft battery. That didn't fix the issue. If I pull the fuse for the "front wiper logic" inside the cab they will stop.
Today I decided to take a look around that fuse block inside and the wipers came on and wouldn't go off. The truck was off. No sprayer this time. I then had to find the wiper fuse under the hood and pull that to get it to stop.

If I disconned the multifunction switch the wipers do not turn off. Is this a BCM issue or could it just be a wiper motor issue?

Thanks all
Reply With Quote
  #2  
Old 12-17-2012, 10:09 AM
tbe2002 tbe2002 is offline
New User
 
Join Date: Feb 2010
Posts: 6
tbe2002 is starting off with a positive reputation.
Issues got worse last night after the post. Took it to the dealer. Ended up with no turn signals in the front only. No turn signals on the mirrors. Blubs are good. Just a fas flash as if a bulb is out. No easy out on the seat and a brake light in the instrument cluster. Ill keep you all updated as to what they find. Hoping there are bcm codes to direct them somwhere.

Yeppie...... Not.
Reply With Quote
Old 12-17-2012, 10:09 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wipers won't turn off......sometimes! gmhorse 6.7L Power Stroke Diesel 29 12-04-2014 02:22 PM
Dead windshield wipers AbandonedBronco 1978 - 1996 Big Bronco 2 10-12-2013 07:03 PM
Wipers won't turn off... ToMang07 Super Duty & Heavy Duty 14 06-17-2013 10:29 PM
Wipers and glow plug issue Jbrown8988 Super Duty & Heavy Duty 0 11-23-2012 06:29 PM
WS wiper motor burned???? on my 2000 EXP ARK Ranger Expedition & Navigator 5 12-11-2008 04:50 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 04:28 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup