2006 EXPEDITION 5.4 ENG PROBLEMS - Ford Truck Enthusiasts Forums



1997-2006 Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator Discussion

2006 EXPEDITION 5.4 ENG PROBLEMS

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-11-2012, 06:04 PM
BRKDR BRKDR is offline
New User
Thread Starter
 
Join Date: Dec 2012
Posts: 1
BRKDR is starting off with a positive reputation.
2006 EXPEDITION 5.4 ENG PROBLEMS

ENGINE HAS TAPPING SOUND LIKE STUCK LIFTER AND HAS BAD MISS AND ROUGH IDLE . WHEN DRIVING SOUNDS LIKE ITS LABORING LIKE THE OLD DAYS WHEN U USED CHEAP GAS . I PULLED THE CODES AND HERS WHAT CAME UP PO172,PO174,PO300,PO303,PO304,PO304,PO420. HAS TO BE SOMETHING CAUSING THESE CODES ANY IDEAS ON WHERE TO START WITH THIS. THANKS IN ADVANCE
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
help needed tomeug69 Explorer, Sport Trac, Mountaineer & Aviator 2 12-10-2015 09:48 PM
4.2 po300 Duncan Scott Millar 1968-2013 Full Size Vans 18 08-23-2015 01:22 PM
2006 Expedition 5 Error Codes JPG7 1997-2006 Expedition & Navigator 4 06-13-2015 12:28 AM
30 lbs compression on cylinder 4 Don1962 1997 - 2003 F150 6 01-16-2015 07:47 AM
Po304 po308 FFEMT32 Modular V10 (6.8l) 2 05-10-2013 08:31 AM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 04:17 PM.