No spark & scanner says "no link" - Ford Truck Enthusiasts Forums

No spark & scanner says "no link"

LinkBack Thread Tools Search this Thread
Old 12-09-2012, 02:23 PM
hendedo hendedo is offline
Junior User
Thread Starter
Join Date: Nov 2008
Posts: 61
hendedo is starting off with a positive reputation.
No spark & scanner says "no link"

Hello all. 99 F-150 4.2L, Auto, 185K miles, 2WD

Truck has been parked for about 12 months. Started regularly and has never given a sign of real trouble. Now, it has no spark.
Recent (within 10K miles) coil pack, Morotcraft plugs, Motorcraft wires. Plugs look good, not too sooty and electrode is tan. Engine turns over fine. Plug going into coil pack has power on the forward wire when key is on. But none of the other 3 wires have power when cranking or static.
Sprayed starter fluid into throttle body; Nothing. I expected it to at least fire/backfire, spit, cough...something.
Looked at fuses and all appeared good. Is a relay in the box under the hood that has a crack in the black plastic housing; not sure if thats it.
Put my scanner in and it read "no Link" Saw this once before and I had a bad 20 amp (yellow) fuse. But they are all ok.

I know this is a tough one but where do I start? Thank You for thinking on this one.
Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Blew a spark plug then more strange things... navyguy79 1997 - 2003 F150 30 07-08-2015 04:59 PM
no spark; how do I test coil? 4.2L hendedo 3.8 & 4.2L V6 0 09-22-2013 06:39 PM
No spark + "No Link" code hendedo 1997 - 2003 F150 4 12-11-2012 05:24 AM
uh oh no spark.. hendedo 3.8 & 4.2L V6 0 10-21-2012 02:18 PM
Misfiring/no spark. whallene Ranger & B-Series 5 08-21-2011 05:46 PM

Go Back   Ford Truck Enthusiasts Forums > >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

All times are GMT -5. The time now is 09:59 AM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.