Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > 2011 & Newer Explorer
Sign in using an external account
Register Forgot Password?


2011 & Newer Explorer Discuss the all new redesigned Ford Explorer

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 11-25-2012, 10:18 AM
montey2005 montey2005 is offline
Senior User
 
Join Date: May 2012
Location: Frisco, TX
Posts: 301
montey2005 is gaining momentum as a positive member of FTE.
daxrizo
2012 Explorer's Sync

I don't get a chance to drive the wife's vehicle but when I do I start fiddling with the Sync system and have come to realize that it plainly just SUCKS! All those who have said fire everyone involved with it is dead on. I'm really getting annoyed to the point that I might convince my wife to sell the thing and go back to Benz. We have no "call" commands that work and no bluetooth player connectivity or controls and those are just two problems. Has anyone updated their software and gotten back such controls? We did not pay this premium for a half *** system. Your input would be greatly appreciated.

Thanks.
Reply With Quote
  #2 (permalink)  
Old 11-25-2012, 07:43 PM
Jam3z Jam3z is offline
Junior User
 
Join Date: Apr 2008
Posts: 52
Jam3z is starting off with a positive reputation.
Montey it sounds like you have a problem that the dealer needs to fix. My 2012 has had and still has clunky software and occasional glitches but the phone has always worked. If you have no bluetooth that might explain why the phone won't function since it uses that connection. That could be either a hardware or software problem.
You can eleminate the software problem by first trying a "master reset." It is found in the system menu. Probably easier if you go by the steps in your owners manual as nothing is intuitive about sync. That will reload your software. If that does not change anything you might try downloading the latest update from the syncmyride website. That too is not easy but can be done if you give it several tries. Then install the update in your Explorer. That part works pretty well. The update reinstalls the whole system so anything bad in your current software should be replaced.
If the updated software does not change anything for you then you have a hardware problem.
I hope that you are still under warranty.

My dealer offered to install the last two updates for me. I declined but had so much trouble with the last one that I will probably let them do the next one. Calling the support phone number was no help at all. They said my computer was not set right and they would not help with that. I used the dealer's computer and had the same trouble. Good thing that it did not download for a few days since they put a bad version of the update on their website and everyone that installed it had problems which they could only fix by downloading and installing the fixed update.

Ford does not have a handle on this system. They are now fixing the fixes and it still has bugs. You and others are right that some people responsible for the touch system do need to get fired. Hopefully the replacements will start by actually listening to their customers.

Good luck!
Reply With Quote
  #3 (permalink)  
Old 11-25-2012, 09:30 PM
montey2005 montey2005 is offline
Senior User
 
Join Date: May 2012
Location: Frisco, TX
Posts: 301
montey2005 is gaining momentum as a positive member of FTE.
daxrizo
thanks for the response. I will call the Ford house tomorrow. i did call the sync 800 number and they are useless!!!!! I can read the manual, and have, just like they did. I also did a master reset to no avail.

Will let you guys know the progress.
Reply With Quote
  #4 (permalink)  
Old 11-27-2012, 07:31 AM
gcr33 gcr33 is offline
New User
 
Join Date: Sep 2009
Posts: 1
gcr33 is starting off with a positive reputation.
While a little off subject I had an 11 LTD and just got a 13 LTD. The blue tooth noise is goine and it sees after 1 day that the whole thing is much better. We will see.
Reply With Quote
  #5 (permalink)  
Old 11-29-2012, 10:17 PM
montey2005 montey2005 is offline
Senior User
 
Join Date: May 2012
Location: Frisco, TX
Posts: 301
montey2005 is gaining momentum as a positive member of FTE.
daxrizo
The red lash fixed most of the problems but sync still sucks, this system is cumbersome. When my iPhone is connected you see it on the screen and the yellow light changes from 1 to 3rd position. What does this mean? I did notice some of the features on my iPod aren't working via Bluetooth when it jumps positions. See below for pic.
Click the image to open in full size.
Reply With Quote
  #6 (permalink)  
Old 11-30-2012, 08:29 PM
ArmamentDawg's Avatar
ArmamentDawg ArmamentDawg is offline
Junior User
 
Join Date: Sep 2005
Location: Newport News, VA
Posts: 63
ArmamentDawg is starting off with a positive reputation.
Scott A. Bregi
The different lights denote one of three screens that can be viewed. If you press the red area it will switch between the different views.
__________________
Posted by Scott proud owner of a
Ruby Red 2013 Explorer XLT

SSG U.S. Army, Retired

"Imagination is more important than knowledge" - Albert Einstein
Reply With Quote
  #7 (permalink)  
Old 11-30-2012, 11:18 PM
montey2005 montey2005 is offline
Senior User
 
Join Date: May 2012
Location: Frisco, TX
Posts: 301
montey2005 is gaining momentum as a positive member of FTE.
daxrizo
I pressed it and nothing changed, not on the outside but directly where it says Dax's Iphone. No screen change.
Reply With Quote
Old 11-30-2012, 11:18 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > 2011 & Newer Explorer

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 02:09 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup