Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator
Sign in using an external account
Register Forgot Password?


Expedition & Navigator 1997 - 2002 and 2003 - 2006 Ford Expedition and Lincoln Navigator SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 05-22-2003, 02:45 PM
FordPower2000 FordPower2000 is offline
New User
 
Join Date: May 2003
Posts: 14
FordPower2000 is starting off with a positive reputation.
Question 2000 Expedition - ABS Light On

The light on my 2000 Expedition EB 5.4L just turned on. I have not done any brake jobs recently. When you turn on the car the ABS light tunrs on as normal. After about 3 seconds it turns off then comes back on and stays on.

What can be wrong? Is this something simple to fix?

The manual says when the light stays on that the ABS system is not working and is disabled. I've read in a thread that changing the ABS speed sensor on the rotor might correct this problem. How can I tell if the sensor is bad?

What else can cause this?
Reply With Quote
  #2 (permalink)  
Old 06-04-2003, 06:50 AM
P-Bod P-Bod is offline
New User
 
Join Date: Jun 2003
Posts: 11
P-Bod is starting off with a positive reputation.
2000 Expedition - ABS Light On

See my post here:

http://www.ford-trucks.com/forums/sh...22abs+light%22

It was a quick fix that cost less than $22. All you need is a 3/8" socket to remove the rear-diff sensor.
Reply With Quote
  #3 (permalink)  
Old 06-04-2003, 12:09 PM
willica1 willica1 is offline
Junior User
 
Join Date: Aug 2002
Location: South Fork
Posts: 50
willica1 is starting off with a positive reputation.
2000 Expedition - ABS Light On

I have a similar problem on my 99 Expy. Except mine is sporadic and only comes on occasionally, usually after a sharp and/or quick turn. If you turn the ignition off and back on, the light goes out. Do you think this could be fixed by replacing the speed sensor in the differential?
__________________
2Lazy


06 F150 XLT SC
5.4L 4X4
Reply With Quote
Old 06-04-2003, 12:09 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Expedition & Navigator

Tags
2000, abs, expedition, expidition, f150, ford, fuze, light, lights, located, navigator, sensor, staying, stays, system

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 08:25 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup