Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Ford V6 > 3.7, 3.5 and 3.0 Duratec V6
Sign in using an external account
Register Forgot Password?


3.7, 3.5 and 3.0 Duratec V6 Forum for the 3.7, 3.5 and 3.0 naturally aspirated Duratec V6 Engines

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-20-2012, 11:41 PM
nwgal65 nwgal65 is offline
New User
 
Join Date: Nov 2012
Posts: 6
nwgal65 is starting off with a positive reputation.
is it likely my oil pressure pump?

Hi...any help is very much appreciated. I have a 2001 Ford Escape XLT. I am the original owner and have taken good care of it. It has 180,000 miles and yesterday my oil light came on. Jiffylube topped it off with High Mileage Oil, which is what I have been using as of late. It took a quart and I had previously had my oil changed on 10-1-12, only 1500 miles ago at most. Over the past year, I have found that my oil is low by a quart if I wait the 3000/4000 miles or 3 months. 24 hours later, today, the light came on again. Jiffylube checked and said I didn't need much oil, but oil light was on, although it does flicker at times, and goes off for a minute or so after I accelerate. The guy at Jiffyluibe said it was probably my oil pressure pump and that I could risk seizing my engine if it is not fixed. He referred me to a mechanic, who said he just put in a used engine into another 2001 Ford Escape and said that he thinks the oil pressure pumps tend to go at about this mileage. He suggested I get a used engine with about 80,000 miles and would replaced it for a total of around $1800 ($1300 for the engine.) I'm tempted, but I'm an idiot when it comes to mechanical things. Any advice?? Thank you!
Reply With Quote
  #2  
Old 11-21-2012, 08:59 PM
nwgal65 nwgal65 is offline
New User
 
Join Date: Nov 2012
Posts: 6
nwgal65 is starting off with a positive reputation.
I don't see a way to delete this thread. I took my car to a mechanic and the gauge showed I have low oil pressure. One hypothesis is that it is a tube that is clogged (cheaper to fix) ...or the oil pressure pump.
Reply With Quote
Old 11-21-2012, 08:59 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
No oil pressure & light on; rattling noise Huddle House 1997 - 2003 F150 7 06-29-2014 01:17 AM
88 Oil Pressure Issues?! Help! Art5 1978 - 1996 Big Bronco 25 10-19-2013 04:49 PM
Is it likely my oil pressure pump? nwgal65 Oil & Lubrication 8 11-22-2012 12:08 PM
2001 7.3 PSD Coolant and Additive questions SD Rick 1999 - 2003 7.3L Power Stroke Diesel 5 12-29-2010 11:20 AM
New Filter=Tranny Slip??....We'll See!! Rmcmorris Aerostar 5 01-26-2003 06:28 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Ford V6 > 3.7, 3.5 and 3.0 Duratec V6

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 11:08 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup