Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-20-2012, 10:16 AM
jim200 jim200 is offline
New User
 
Join Date: Jul 2009
Posts: 4
jim200 is starting off with a positive reputation.
Banging from rear end upon acceleration

I have a '99 Expedition EB with 230,000 miles. Yesterday when I was accelerating to merge onto the interstate, there was a loud banging coming from underneath the vehicle. It stopped when I got up to speed, and it didn't happen again until I was accelerating onto the interstate to return home. I crawled under the vehicle this morning and noticed a coating of grease from where the drive shaft enters the rear end, to the differential cover. It was black and thick, and appears to have been there for a while, but there is nothing on my garage floor. Could this leak be related to the banging? Is this going to cost big bucks to repair? Thanks for any advice!
Reply With Quote
Old 11-20-2012, 10:16 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loud Bang When in 4x4? (93 F250) colliebrookcrossing 1987 - 1996 F150 & Larger F-Series Trucks 4 12-18-2013 08:39 AM
99 EXP A4WD BANGING IN FRONT END UNDER HARD ACCEL CHIEFSOU Expedition & Navigator 9 08-30-2013 08:11 AM
Transmission Bang Shifting - Overdrive Off Light Flashes NickInFC Explorer, Sport Trac, Mountaineer & Aviator 18 07-23-2013 06:25 PM
2004 Expedition Rubbing/Vibration Noise hz36t5 Expedition & Navigator 9 01-29-2013 04:16 PM
2012 escape trans banging billydsr25 Escape & Escape Hybrid 16 12-29-2012 05:43 AM



All times are GMT -5. The time now is 02:35 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup