Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-24-2012, 12:39 PM
creekfreak1 creekfreak1 is offline
New User
 
Join Date: Oct 2012
Posts: 2
creekfreak1 is starting off with a positive reputation.
misfire #2

About at the end of my patients. On a trip to fl lost power and ran horrible. Repaced 1 coil pac and all plugs. Still ran rough but got us home. Since then I've switched coils,fuel injectors,plugs. Now cant pass emissions. Very little heat in cab and smell of anti freeze. Also losing oil ,no driveway marks. 2000 expedition 8th digit 6. Please help!
Reply With Quote
  #2  
Old 11-01-2012, 05:47 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Sounds like a blown motor. Do compression check on all cylinders. This should have been done first.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
Old 11-01-2012, 05:47 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Put truck back together, now engine code p0351 mfp4073 Ranger & B-Series 3 06-17-2014 02:38 PM
please help 2000 ford 5.4 trition xlt milwaukee2000 1997 - 2003 F150 6 12-24-2013 05:55 PM
Keep getting misfires jhammersmark 1997 - 2003 F150 2 07-27-2013 02:30 PM
Multiple coil pack failures????? tibbytom Super Duty & Heavy Duty 1 01-22-2013 08:12 PM
5.4 Coil Test ? gyrocopter1 1968-2013 Full Size Vans 7 01-02-2013 05:04 AM



All times are GMT -5. The time now is 03:37 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup