Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-18-2012, 11:02 PM
slider6075 slider6075 is offline
New User
 
Join Date: Oct 2012
Location: newnan, georgia
Posts: 10
slider6075 is starting off with a positive reputation.
drivetrain problems 05 expeditiom

Drivinf my 05 eddie bauer expedition today when it stoppes going forward and od light came on and check throttle control came on. Threw code p0720 which is output speed sensor and p2106 which deals with throttle body. I could go in reverse fine but no forwars gars. I unplugged the output speed sensor on tranny and the connection was full of red atf fluid. Something tells me this isnt right. All connections just dripping with fluid. Could the sensor be cracked and leaking fluid into it causing a problem? I am going to clean throttle body and maf sensor also. Thanks
Reply With Quote
Old 10-18-2012, 11:02 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Expedition Check Electronic Throttle Control, P0720, P2106, O/D Off Blinking, Limited Power WhyFord Expedition & Navigator 21 06-27-2013 03:29 PM
2004 f150 Limp mode P0722 PO713 faults jeremeh83 2004 - 2008 F150 4 06-04-2013 09:48 AM
Transmission Problems brandon. 2004 - 2008 F150 5 12-07-2012 05:35 AM
05 expedition output speed sensor slider6075 Clutch, Transmission, Differential, Axle & Transfer Case 14 10-23-2012 09:27 PM
P2614 Cam shaft Sensor Problem solved Curt's05 6.0L Power Stroke Diesel 0 08-20-2012 08:38 PM



All times are GMT -5. The time now is 02:16 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup