drivetrain problems 05 expeditiom - Ford Truck Enthusiasts Forums

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Log In 

2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

drivetrain problems 05 expeditiom

LinkBack Thread Tools Search this Thread
Old 10-19-2012, 12:02 AM
slider6075 slider6075 is offline
New User
Join Date: Oct 2012
Location: newnan, georgia
Posts: 10
slider6075 is starting off with a positive reputation.
drivetrain problems 05 expeditiom

Drivinf my 05 eddie bauer expedition today when it stoppes going forward and od light came on and check throttle control came on. Threw code p0720 which is output speed sensor and p2106 which deals with throttle body. I could go in reverse fine but no forwars gars. I unplugged the output speed sensor on tranny and the connection was full of red atf fluid. Something tells me this isnt right. All connections just dripping with fluid. Could the sensor be cracked and leaking fluid into it causing a problem? I am going to clean throttle body and maf sensor also. Thanks
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Expedition Check Electronic Throttle Control, P0720, P2106, O/D Off Blinking, Limited Power WhyFord Expedition & Navigator 21 06-27-2013 04:29 PM
05 expedition output speed sensor slider6075 Clutch, Transmission, Differential, Axle & Transfer Case 14 10-23-2012 10:27 PM
QUESTION ON P2104 CODE / TPS magnet1 2004 - 2008 F150 7 12-17-2010 03:29 AM
CODE P0506 PITTF150 2004 - 2008 F150 5 06-09-2010 11:35 AM
Output speed sensor-DTCs-99'ford f-250 4 WD rajah Super Duty & Heavy Duty 5 07-22-2004 07:39 AM

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

All times are GMT -5. The time now is 05:16 AM.


Advertising - Terms of Use - Privacy Statement - Terms of Service - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup