Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-04-2012, 11:46 AM
I Love My Truck's Avatar
I Love My Truck I Love My Truck is offline
Freshman User
 
Join Date: Dec 2010
Location: Kingwood, Texas
Posts: 33
I Love My Truck is starting off with a positive reputation.
Need Help with a headlight problem

I need some direction on an issue I'm having with my wife's 2006 Navigator. The left low beam headlight/DRL wasn't working. I bought replacement HID bulb and installed it. It still didn't work. I checked the #25 fuse and it was fine. I took the old HID bulb and installed it in the right headlight and it worked. I swapped both the lowbeam bulbs and ballasts/amplifiers from left to right and still couldn't get the left head light to work. I'm not sure what to do next. Any help is greatly appreciated. Thanks
Reply With Quote
  #2  
Old 11-15-2012, 02:50 PM
sicksoh's Avatar
sicksoh sicksoh is offline
Junior User
 
Join Date: Dec 2009
Posts: 57
sicksoh is starting off with a positive reputation.
Hey did you ever get this figured out? Sounds like we are having the same issue. I have checked everything and it all works opposite also. I am picking up a new relay today to see if that solves the problem. Mine works when it wants to.
Reply With Quote
Old 11-15-2012, 02:50 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Low beams don't work but high beams do dee_011 1997 - 2003 F150 5 09-29-2014 04:55 PM
HID Headlight question (wiring issue) robert_l_ross Excursion - King of SUVs 2 12-30-2013 10:43 PM
newbie here w/ a Hid question api5471 Super Duty & Heavy Duty 4 11-14-2013 12:48 PM
HID headlights Brad2296 Electrical Systems/Wiring 19 01-06-2011 05:47 AM
Left Headlight went dim... dirtjb18 Electrical Systems/Wiring 7 01-10-2006 08:21 PM



All times are GMT -5. The time now is 02:52 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup