Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-21-2012, 08:54 AM
RRANDAL RRANDAL is offline
New User
 
Join Date: Dec 2005
Posts: 4
RRANDAL is starting off with a positive reputation.
Rear-break, Hazard, and turn signals not working



Hello all,

Vehicle - 2007 Expo limited, EL.

My rear break lights, rear hazards, and rear turn signals are out. Strange thing is my tail lights work at night but no break lights. All front lights work and the third break light up top works just fine. I replaced the multi-function switch /arm on the steering column and no luck. Any thoughts anyone?
Reply With Quote
Old 09-21-2012, 08:54 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Right turn signal/Hazard light/Brake light Problem bigboylk Excursion - King of SUVs 4 06-17-2014 04:35 PM
hazards/1 bulb not working B-2 1973 - 1979 F-100 & Larger F-Series Trucks 4 01-16-2013 10:23 PM
Very strange Hazard/Warning Lights Deer545 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 7 12-20-2012 01:58 PM
Turn Signal malfunction Ohiosavage83 1999 - 2003 7.3L Power Stroke Diesel 5 10-16-2012 08:06 PM
Odd Electrical issue with turn signals - help! dylan8427 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 6 09-08-2012 08:14 AM



All times are GMT -5. The time now is 07:51 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup