Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2004 - 2008 F150
Sign in using an external account
Register Forgot Password?


2004 - 2008 F150 2004, 2005, 2006, 2007 and 2008 Ford F150's with 5.4 V8, 4.6 V8 or 4.2 V6 engine
SPONSORED BY:
Click HereAdvertisement

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #31  
Old 10-22-2013, 07:18 PM
friscofordguy friscofordguy is offline
Freshman User
 
Join Date: Sep 2008
Posts: 29
friscofordguy is starting off with a positive reputation.
Charz, I'm having similar symptoms. What did your mechanic find?
Reply With Quote
  #32  
Old 04-01-2014, 06:53 PM
charz charz is offline
Junior User
 
Join Date: Aug 2012
Posts: 53
charz is starting off with a positive reputation.
Quote:
Originally Posted by friscofordguy View Post
Charz, I'm having similar symptoms. What did your mechanic find?
I've just been running lucas in it and driving, I'm not putting another penny into fixing the motor if it stops working then I'll just drop a jasper in it.
Reply With Quote
  #33  
Old 04-15-2014, 08:43 PM
bfl4 bfl4 is offline
New User
 
Join Date: Apr 2014
Posts: 4
bfl4 is starting off with a positive reputation.
bfl4@pitt.edu
Quote:
Originally Posted by charz View Post
So after a decent drive when I get to a redlight/stopsign/etc the truck will idle rough and shake but giving it a little bit of gas (1k RPM) seems to smooth it out however it doesn't throw any codes or the CEL. The truck is a 2008 F150 with the 5.4 and 90k miles.

I've searched quite a bit on this issue and I can't seem to find any real fixes other than swap parts out until something works and I've heard everything from filters to cam phasers or low oil pressure (I will be taking it to the mechanic to check the oil pressure)

so far I've:
Replaced the air and fuel filters
Changed the oil and oil filter (synthetic and oem filter)
cleaned the MAF and cleaned the throttle body

also is the 2008 equipped with an IAC Valve because I've read that it wasn't and I can't seem to find the IAC if it is.
--------------------------------------------------------------------------

I had the same problem on my 2004 5.4L had a rough idle, also noticed a rattling noise coming from the right side hub while driving, and my cruise control would work on and off. Turned out it was a vacuum problem. I replaced the vacuum valve on the driver side fire wall (~15$) and the vacuum reservoir that sits behind the battery, its a little black box that holds pressure found one at a local junk yard for 10$. When you change this out I would also look at the connectors throughout the vacuum lines to make sure they aren't clogged up. After I did all that my rough idle disappeared, hub noises disappeared, and my cruise control worked whenever I needed it too.

Good Luck
Reply With Quote
Old 04-15-2014, 08:43 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
'04 Ranger heater won't warm up while idling... Furyus1 Ranger & B-Series 18 01-04-2013 07:38 PM
2005 Mariner idle sundvl76 Escape & Escape Hybrid 20 12-07-2010 06:09 AM
jumpy idle. fords and kenworths Explorer, Sport Trac, Mountaineer & Aviator 2 12-03-2007 10:44 AM
89 351W surging at cruise throttle whiteyfordzx5 1987 - 1996 F150 & Larger F-Series Trucks 7 09-10-2007 05:21 PM
Rev engine at 3K it starts chugging/stutter tm3912 Explorer, Sport Trac, Mountaineer & Aviator 8 07-28-2007 02:22 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2004 - 2008 F150

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 05:45 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup