Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Lightning, Harley-Davidson F-150, Roush F-150 & Saleen F-150
Sign in using an external account
Register Forgot Password?


Lightning, Harley-Davidson F-150, Roush F-150 & Saleen F-150 SVT Ford F150 Lightning, Roush, Saleen and other performance F150's

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-06-2012, 05:12 PM
Luthier Luthier is offline
Freshman User
 
Join Date: Sep 2012
Posts: 37
Luthier is starting off with a positive reputation.
Serouisly Bad Electrical Day

Wow, sorry to do this but,, was there any resolve to this issue/issues??
I have an 2003 SC F150, with these issues and more.
Things that aren't working;
Power Windows
Moon Roof
Interior front roof console courtesy lights
Hazard Flashers
Turn Signals
OBD Port
Radio Back light
A/C Module back light
Door Ajar bell
Brake not engaged safety feature to release shifter lever
Engine compartment Hood Lamp
A/C blower stuck @ high speed
Probably more, I started crying at this point(Close) like an idiot....

Here's what happened, Engine over heated due too a relay on my E-Fan, my trailer was attached at the time the relay died causing it to over heat.
Water did not go in to engine bay at all, I didn't have to rinse anything off either.
Next day the turn signals started to act sporadically. Changed out Relay #4 to no avail.
Next was to be the Flasher Relay next to the A/C blower relay that resides under the dash next to the console.
I pulled both out to determine which was which, upon figuring that out which it was, I replaced the proper one (Blue) in color and reinserted the other to no avail,,, so I thought....but wait this is where it gets good,,,

Now all the above is going on. Currently detached the battery and charging it to insure a fully charged battery, in hopes it may have been the cause and to re-set the electronics.....

PLEASE HELP
Reply With Quote
  #2  
Old 09-07-2012, 10:37 AM
Lead Head Lead Head is offline
Postmaster
 
Join Date: Jul 2007
Location: Rhode Island
Posts: 4,836
Lead Head has a great reputation on FTE.Lead Head has a great reputation on FTE.Lead Head has a great reputation on FTE.Lead Head has a great reputation on FTE.Lead Head has a great reputation on FTE.Lead Head has a great reputation on FTE.
Sounds like a General Electronics Module failure to me. You've checked all the fuses right?
__________________
- Ian

1987 Ford Ranger XLT 4x4 2.9

Needs a lot of work, including some rot on the body, but shes getting there.
Reply With Quote
  #3  
Old 09-07-2012, 10:53 AM
Luthier Luthier is offline
Freshman User
 
Join Date: Sep 2012
Posts: 37
Luthier is starting off with a positive reputation.
Yeah that's where I'm at now, I have checked all fuses, breakers, relays etc.... Found one on Flea Bay and made an offer.
Do you know if they require per-programming prior to installation or after. It is a new module so I know/assume it will need some type of programing correct?

Lesson to all, be careful as to what fuses you jumper things off of and as to what load the things one is jumping have and or will draw.........................
Reply With Quote
  #4  
Old 09-07-2012, 10:58 AM
Poolshark1321 Poolshark1321 is offline
Freshman User
 
Join Date: Sep 2012
Posts: 32
Poolshark1321 is starting off with a positive reputation.
That is a big nightmare, I wish you the best of luck... sorry I cant offer advice/help but I am not an electrical guru.
Reply With Quote
  #5  
Old 09-07-2012, 11:01 AM
Luthier Luthier is offline
Freshman User
 
Join Date: Sep 2012
Posts: 37
Luthier is starting off with a positive reputation.
Thanks, sometimes a best wish can keep a grown man from crying.. :-)
Reply With Quote
  #6  
Old 09-07-2012, 11:15 AM
Poolshark1321 Poolshark1321 is offline
Freshman User
 
Join Date: Sep 2012
Posts: 32
Poolshark1321 is starting off with a positive reputation.
For it to knockout all that stuff at once definitely makes me think its ECU or something along thsoe lines. Normally it would just be one thing or maybe a few things tied together... but all of that crap at once is insane.
Reply With Quote
Old 09-07-2012, 11:15 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > Lightning, Harley-Davidson F-150, Roush F-150 & Saleen F-150

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 explorer check charging system stumped22 Explorer, Sport Trac, Mountaineer & Aviator 12 07-21-2014 05:26 PM
Multi-function switch or flasher or flasher relay? Phanman43 Expedition & Navigator 12 03-04-2014 07:08 PM
Weird: Hazard / Turn Signal / Heater & AC Control Issue cpye2 Super Duty & Heavy Duty 4 12-27-2013 01:16 PM
Electrical Issues, Need help big time GreenTerracePSD 1999 - 2003 7.3L Power Stroke Diesel 19 06-26-2013 05:07 PM
Electrical Germlin,, HAH,,,More like an Oger Luthier Electrical Systems/Wiring 28 09-30-2012 06:51 PM



All times are GMT -5. The time now is 05:07 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup