Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Crossovers
Sign in using an external account
Register Forgot Password?


Crossovers Edge, Taurus X, Freestyle, MKX, Flex etc.

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 09-03-2012, 06:22 PM
hillbilly1025 hillbilly1025 is offline
Junior User
 
Join Date: Nov 2005
Posts: 78
hillbilly1025 is starting off with a positive reputation.
'12 edge tranny hesitation

recently bought my wife a FWD 2012 edge, it has 10,600 miles on it and we both really like it. it rides better than some of our friends' new vehicles and has more power. The only issue we have noticed is a slight hesitation in the tranny. This is most noticeable when backing out of the driveway and a car pops around the corner and we out it in drive and nothing, it seems like a few seconds before anything happens. Anyone else having this problem? Any ideas?
Reply With Quote
  #2 (permalink)  
Old 11-04-2012, 07:06 AM
fixdent fixdent is offline
Senior User
 
Join Date: Jul 2010
Location: Northwestern Ontario
Posts: 261
fixdent is gaining momentum as a positive member of FTE.
We have the same issues with our 2010 Edge. about 35000 kms on it now.
It seems more prevelant in the colder temps, and now that it is getting cold it's getting worse again.

When crossing an intersection, the vehicle will start to cross, then hesitate for a few seconds, and then BAM, you would think someone has rear-ended you and across you go....very scary, especially if someone is coming up to the intersection from the side and you are trying to get across.

I am going to contact our Ford dealer this week.

--
Gordon
Reply With Quote
  #3 (permalink)  
Old 04-27-2013, 10:21 AM
Culvert Culvert is offline
Senior User
 
Join Date: Jul 2004
Location: Cold Lake, Ab
Posts: 291
Culvert is starting off with a positive reputation.
Did anyone get a fix for this situation? Our friend has a 2012 Edge & she has complained to Ford about this same situation.
On the first drive of the day & things are cold it hesitates 2-3sec when she tries to take off then BAM its moving. Not good at intersections or merging with tracffic.

Of course its warmed up & never happens at the dealer.
__________________
06 F350 6.0L CC FX4, ISSPRO EVII EGT & FP gauges, 4" AFE TB exhaust
12 Edge - wife
01 F150 SC 4x4 - duaghter

66 Fairlane 500XL - project
Reply With Quote
  #4 (permalink)  
Old 04-27-2013, 11:35 AM
fixdent fixdent is offline
Senior User
 
Join Date: Jul 2010
Location: Northwestern Ontario
Posts: 261
fixdent is gaining momentum as a positive member of FTE.
The dealer took ours in and did something with the valve body. It seems to be ok now....we had it done in February and haven't had any problems since. I don't know exactly what they did. I could call the dealer and ask.

--

Gordon
Reply With Quote
  #5 (permalink)  
Old 04-27-2013, 07:10 PM
Culvert Culvert is offline
Senior User
 
Join Date: Jul 2004
Location: Cold Lake, Ab
Posts: 291
Culvert is starting off with a positive reputation.
Thanks fixdent.
If you get a chance that would be nice to know what fixed the issue. Clean TB, an adjustment or reprogram?
__________________
06 F350 6.0L CC FX4, ISSPRO EVII EGT & FP gauges, 4" AFE TB exhaust
12 Edge - wife
01 F150 SC 4x4 - duaghter

66 Fairlane 500XL - project
Reply With Quote
  #6 (permalink)  
Old 08-13-2013, 07:52 AM
BAD RONALD BAD RONALD is offline
Senior User
 
Join Date: Mar 2011
Location: Fairfield CT
Posts: 316
BAD RONALD is starting off with a positive reputation.
Quote:
Originally Posted by Culvert View Post
If you get a chance that would be nice to know what fixed the issue. Clean TB, an adjustment or reprogram?
If you haven't already serviced the issue, check out this post. The TSB description specifies forward hesitation as well.

So far so good with the modification done on our 2011.

http://www.ford-trucks.com/forums/12...t-11-edge.html
Reply With Quote
Old 08-13-2013, 07:52 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > Crossovers

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 06:42 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup