Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-31-2012, 08:28 PM
nlaao03 nlaao03 is offline
New User
 
Join Date: Jul 2012
Posts: 9
nlaao03 is starting off with a positive reputation.
Need Help. P0012, Im stumped

I have a 2005 f-150 5.4 3V. I bought it used with 136xxx miles knowing it had a problem. Code p0345. When it warmed up and idled around parking lots ect... it would somtimes make a clunk and start idling really bad(making that diesel sound.) I enjoy learning about motors so I thought I would try to tackle this. I have receipts from the PO showing a local mechanic doing the timing kit, sparkplugs. On the drivers side only he replaced the exhaust manifold gasket, Lash adjusters, VCT solenoid, and cam sensor. He also said he had the oil pressure checked and it was good.

Now the things I have done: Replaced both cam phasers, The other vct solenoid and cam sensor. When I took the passenger side valve cover off I noticed on the #4 cylinder the very last rocker and cam lobe was tore up. Cam lobe was wearing into the roller rocker. Why it was apart I changed the camshaft, 12 lash adjusters, the one bad roller rocker. I inspected the other and they appeared good. After putting it all back together it runs the same. the only difference is it is throwing a p0012 code now. I went and had the oil pressure checked myself and it was at steady 30 psi at hot idle. I marked the cam phasers, camshaft, caps on the camshaft, and put the rockers back in there origanal locations. Now Im stupped and don't know what to do next. The only thing I can think of is taking the front cover off and make sure the timing is right. Any help or ideas will be greatly appreciated.
Reply With Quote
  #2  
Old 09-01-2012, 10:27 PM
70f100longbed's Avatar
70f100longbed 70f100longbed is offline
Posting Guru
 
Join Date: Aug 2002
Location: Raleigh USA
Posts: 1,071
70f100longbed has a very good reputation on FTE.70f100longbed has a very good reputation on FTE.70f100longbed has a very good reputation on FTE.
Did you use the wedge tool to hold the chain in place? If not then its possible the chain could have moved on the crank, which will require the timing cover to be removed and the cams re-timed. I explain how to time the cams in another thread, search for "timimg a 5.4" (I know its misspelled, thats what the thread is called)
__________________
Ford senior master tech
Every 5.4 3V owner should have Lisle tool #65600
8L3Z-6M280-B updated VCT solenoids for 5.4 3V rattle
Reply With Quote
  #3  
Old 09-02-2012, 12:19 AM
nlaao03 nlaao03 is offline
New User
 
Join Date: Jul 2012
Posts: 9
nlaao03 is starting off with a positive reputation.
Yes I used the wedge tool. I think a timing check would be my next step. I read through that post a couple of times now. I think I'm ready to try it. I was reading through my chiltons and it looks like a pain to remove the timing cover. Do you really need special pullers for the crank and power steering pump. Is there a how to on that somewhere here. I have searched and came up empty. Thanks for all the help.
Reply With Quote
  #4  
Old 09-02-2012, 10:02 PM
70f100longbed's Avatar
70f100longbed 70f100longbed is offline
Posting Guru
 
Join Date: Aug 2002
Location: Raleigh USA
Posts: 1,071
70f100longbed has a very good reputation on FTE.70f100longbed has a very good reputation on FTE.70f100longbed has a very good reputation on FTE.
You need a harmonic balancer puller for the crank pulley and I take off the PS pump with the pulley and lines still on. Those pullies can be a PITA sometimes. A 10mm reversible gearwrench makes getting the pump off a lot easier. There is one bolt that is right behind the pressure line fitting that is hard to get to without the gearwrench.
__________________
Ford senior master tech
Every 5.4 3V owner should have Lisle tool #65600
8L3Z-6M280-B updated VCT solenoids for 5.4 3V rattle
Reply With Quote
  #5  
Old 09-03-2012, 05:24 PM
nlaao03 nlaao03 is offline
New User
 
Join Date: Jul 2012
Posts: 9
nlaao03 is starting off with a positive reputation.
Thanks for tips. I will probably get started in a week or so. I hope this will be it.
Reply With Quote
  #6  
Old 09-21-2012, 10:02 PM
nlaao03 nlaao03 is offline
New User
 
Join Date: Jul 2012
Posts: 9
nlaao03 is starting off with a positive reputation.
I finally got the timing cover off to inspect and retime the motor. One of the tensioners had a bad seal. After looking more closely to them I also noticed I had two Left tensioners instead of a left and right. I got everything back together and the truck went about 3 days before the CEL came back on. When and got it read and still the same p0012. Motor still shakes and knocks when idling around after it is warmed up. Does it every time I drive it. I got referred to a ford mechanic and explained to them my problem and they are telling me to drop oil pan and check the pick-up screen and check the crank bearings for wear. I guess that will be my next step later down the road.
Im open to any and all other suggestions.

One other thing I noticed that looked replaced was the drivers side VCT body looked replaced. I guessing this engine has been around and no one has got it figured out yet.
Reply With Quote
Old 09-21-2012, 10:02 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 5.4 p0012 code - need help diagnosing FoxNotch Super Duty & Heavy Duty 10 09-06-2014 11:58 AM
Questions about VCT System - P0012 and P0021 Codes jtillery Modular V8 (4.6L, 5.4L) 3 08-28-2013 06:20 PM
08 F-250 5.4 VVT Problem when warm parauto 2004 - 2008 F150 8 04-16-2013 11:27 AM
Cam phaser help Fishnutz1 2004 - 2008 F150 2 11-18-2012 07:24 PM
F150 5.4l VCT Trouble - how does it work? C F Industries 2004 - 2008 F150 11 05-04-2011 06:56 PM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Modular V8 (4.6L, 5.4L)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 08:08 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup