Go Back   Ford Truck Enthusiasts Forums > Ford Vans and other vehicles > Ranchero & 1961 - 1967 Econoline
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-29-2012, 09:41 AM
chads chads is offline
New User
 
Join Date: Aug 2012
Posts: 1
chads is starting off with a positive reputation.
Carb problem ?

I have a 66 econoline 170ci with a 1100 carb I just rebuilt as the truck was in storage for well over a year. The truck starts fine and idles fine but when I press on the accelerator, it wants to die out. If I keep the choke a little closed and keep the idle up the problem goes away.
I replaced all the vacuum lines and vacuum advance. No change. I also noticed that the clear fuel filter I put on it only has a little fuel in it when running. (Not sure if that is normal)
Any help would be appreciated.
Reply With Quote
  #2  
Old 09-11-2012, 02:21 AM
kenjh's Avatar
kenjh kenjh is offline
Posting Guru
 
Join Date: Feb 2009
Location: victoria
Posts: 2,009
kenjh has a good reputation on FTE.kenjh has a good reputation on FTE.
have you checked that the accelerator pump is squirting when the throttle is moved ??if the check ball isn't working ..no juice to cover the bog ,,and the choke will give it the rick mix to cover that..and yes some filters never seem to fill but work just fine ..
Reply With Quote
  #3  
Old 11-03-2012, 08:35 PM
l8ntpianist22's Avatar
l8ntpianist22 l8ntpianist22 is offline
Junior User
 
Join Date: Nov 2012
Location: ok
Posts: 64
l8ntpianist22 is starting off with a positive reputation.
im new here,but ken is right on the money
Reply With Quote
Old 11-03-2012, 08:35 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
1959 223 Idle Trouble Spitfire44 1948 - 1956 F1, F100 & Larger F-Series Trucks 1 04-13-2009 07:40 PM
Did I buy the wrong carb? Help please carb gurus! Hellbore Fuel Injection, Carburetion & Fuel System 3 05-23-2006 06:22 PM
Problem with Idle at Startup qman 1967 - 1972 F-100 & Larger F-Series Trucks 1 01-09-2006 11:56 PM
engine dies when in gear dkchristensen Fuel Injection, Carburetion & Fuel System 7 11-08-2002 10:39 PM
problems with brakes and idle speed Strange big4294x4 Big Block V8 - 385 Series (6.1/370, 7.0/429, 7.5/460) 8 09-04-2001 05:30 PM


Go Back   Ford Truck Enthusiasts Forums > Ford Vans and other vehicles > Ranchero & 1961 - 1967 Econoline

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 07:59 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup