Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-03-2012, 02:51 AM
maverick1701's Avatar
maverick1701 maverick1701 is offline
Posting Guru
 
Join Date: Feb 2008
Location: Memphis, TEXAS
Posts: 1,759
maverick1701 has a good reputation on FTE.maverick1701 has a good reputation on FTE.
Citizen GaKar
09 Exped EB- rough idle fixed

Well I finally got my Exped repaired.
It took a 24hr road trip (6hr there, work time then 6hrs back) to get everything fixed...but it was free so we couldn't complain. Joe Watt Auto (where the SO bought our rigs) did all the work and bought me a hotel room so I could sleep while they worked.

Turns out on the pass side, the spring that the truck uses for the variable cam timing failed so stuff was flopping around and causing the motor to be out of time w/itself (periodically) which was causing all the clunking/clanking/rough idle/CEL/flashing CEL/etc.

They went ahead and replaced timing chains while they were in there too.

Maybe this will help someone else fix their issues.
__________________
Chris
1997 Expedition 4x4
2003 KLR650
1968 M35A2 Kaiser Jeep 6x6
2012 Chevrolet Tahoe 4x4 SSV (S.O. Patrol Vehicle)
M998 HMMWV (S.O. SAR vehicle)
Reply With Quote
Old 08-03-2012, 02:51 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
misfire - cylidners 4 & 6 jrobie79 Explorer, Sport Trac, Mountaineer & Aviator 12 02-01-2014 12:42 AM
cleaned ipr, now runs ROUGH, please advise T-wood 1999 - 2003 7.3L Power Stroke Diesel 17 09-12-2013 11:19 PM
Injectors and Coils marye01 Modular V8 (4.6L, 5.4L) 0 08-17-2013 02:54 PM
99 ford f350 7.3l Feonix1123 1999 - 2003 7.3L Power Stroke Diesel 65 04-28-2013 09:39 PM
3V Ford V-10 issues -- HELP! KowboyKyle Modular V10 (6.8l) 2 04-24-2013 12:41 PM



All times are GMT -5. The time now is 03:26 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup