Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator




 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 08-01-2012, 06:55 PM
vamax04 vamax04 is offline
New User
Garage is empty, add now
 
Join Date: Aug 2012
Posts: 1
vamax04 is starting off with a positive reputation.
07 Expedition Hot Air from AC and Coolant Warning

Got in my expedition today, started it up and the AC blows hot, coolant warning light comes on, and the engine temp indicator does not budge. Does anyone have any idea what is causing this. I checked the fuses, disconnected the battery and still does the same thing. I would really appreciate your help.
Reply With Quote
Old 08-01-2012, 06:55 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 08:11 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.



 
vbulletin Admin Backup