Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-06-2012, 11:56 PM
JimLob JimLob is offline
Freshman User
 
Join Date: Jan 2008
Location: Troy, MI
Posts: 31
JimLob is starting off with a positive reputation.
Need informed opinion...engine noise in 2008 Expe

Hello. Am considering buying a 2008 Expedition with 45k on it. Has a slight tick/clatter from both sides near the top of the engine when I load the engine to about 1100-1200 rpm's with my foot on the brake and in gear. Not real heavy, and doesn't really sound like a diesel, but it is there. Could this possbly be a cam phaser issue? Is there any way to diagnose this....disconnect the solenoids?? This is the 2nd used Expe of the same year I have heard this type of noise from and want to make sure it is not going to lead to an expensive repair bill down the road.

Vehicle ran great and is a pretty good deal, but I'd like to make sure...

Thanks.
Reply With Quote
  #2  
Old 07-07-2012, 02:47 PM
5.4T's Avatar
5.4T 5.4T is offline
Elder User
 
Join Date: Mar 2011
Posts: 725
5.4T has a very good reputation on FTE.5.4T has a very good reputation on FTE.5.4T has a very good reputation on FTE.
coulds just need some spark plugs like a tune up
__________________
Reply With Quote
  #3  
Old 07-07-2012, 06:14 PM
JimLob JimLob is offline
Freshman User
 
Join Date: Jan 2008
Location: Troy, MI
Posts: 31
JimLob is starting off with a positive reputation.
Possibly....but it ran awful smooth for needing a tune-up. Actually a plug change will be one of the first things I'll do to it. Unfortunately it missed the cut-off date for having one piece plugs by EIGHT DAYS...bummer but I guess I'll just have to deal with it.

Thanks for the reply
Reply With Quote
  #4  
Old 07-10-2012, 07:02 PM
mudder460's Avatar
mudder460 mudder460 is offline
Posting Guru
 
Join Date: Nov 2006
Location: Navarre, FL
Posts: 1,207
mudder460 is gaining momentum as a positive member of FTE.
Could be the injectors, mine are pretty loud!
__________________
Andy
2008 Expedition Eddie Bauer
Arkansas Chapter Member
Reply With Quote
Old 07-10-2012, 07:02 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 EXP A4WD BANGING IN FRONT END UNDER HARD ACCEL CHIEFSOU Expedition & Navigator 9 08-30-2013 09:11 AM
03 Exp EB right turn screech 99Exp Expedition & Navigator 18 09-17-2009 01:02 PM
98 exp. will not start the_kid23 Expedition & Navigator 0 02-09-2005 08:04 AM
2004 Exp with 4.6 noise when down shifting Green_X_01 Expedition & Navigator 2 10-08-2004 07:30 AM
Suspension squeaks true blue Expedition & Navigator 13 04-07-2002 12:12 AM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 10:07 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup