Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty
Sign in using an external account
Register Forgot Password?


Super Duty & Heavy Duty 1999 to current Ford F250, F350, F450 and F550 Super Duty with diesel V8 and gas V8 and V10 engines SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-15-2012, 03:35 PM
08 fence 450 08 fence 450 is offline
New User
 
Join Date: Jun 2012
Posts: 1
08 fence 450 is starting off with a positive reputation.
2008 F450 with only airbag light on dash

My 450 has all power to lights and aux but no dash lights and only the airbag light will illuminate on the dash and the truck won't start there is absolutely no power being transfered to the starter. It only happens after rain or increasing humidity it seems. Does any one have any ideas???
Reply With Quote
  #2  
Old 01-12-2013, 10:21 AM
kongo1 kongo1 is offline
New User
 
Join Date: Jan 2013
Posts: 5
kongo1 is starting off with a positive reputation.
I am having the same exact same problem! I have a 2008 f250 with a 5.4l and only 27K miles. I have seen numerous post on different web sites from people having the same issue but have never seen a resolution.
I have put a brand new battery in (twice). Truck will run perfect then one day "no start" accompanied by no cluster lights (except for airbag) and no door chimes. Everything else has power but battery is drained down to about 75% overnight. All fuses are good.
Dealer has had it for about a week and a half and can't find anything. Truck was towed there and would not start when it arrived. They charged it and it has been fine since but I know its just a matter of time before it does it again. This is the second time I had to have it towed and the second time a shop can't find the cause. Has anybody solved this very frustrating issue???
Reply With Quote
  #3  
Old 01-12-2013, 10:34 AM
greentree ford greentree ford is offline
Senior User
 
Join Date: Apr 2011
Posts: 322
greentree ford is gaining momentum as a positive member of FTE.greentree ford is gaining momentum as a positive member of FTE.
alot of different places leak. like the windshield, overhead clearance lights causing a short

Start buy looking around fuse box for any signs of moisture
Sometimes moisture get in by the sun visor mounting screw, remove the corner of the overhead liner look of moisture

if you have clearance lights pop of the lens cover look for signs of moisture

look inside of driver door around window motor or power locks

we talking about a gasser or diesel
Reply With Quote
  #4  
Old 01-12-2013, 10:42 AM
kongo1 kongo1 is offline
New User
 
Join Date: Jan 2013
Posts: 5
kongo1 is starting off with a positive reputation.
Thanks for the reply! 5.4 gasser. When I jiggle the #26 fuse ("cluster") on the floor of the passenger side it will sometimes start chiming and the cluster lights will come on but they go crazy and die after about 10 seconds. It also will not take a jump (boost) when the issue arises.
Reply With Quote
  #5  
Old 01-12-2013, 10:46 AM
greentree ford greentree ford is offline
Senior User
 
Join Date: Apr 2011
Posts: 322
greentree ford is gaining momentum as a positive member of FTE.greentree ford is gaining momentum as a positive member of FTE.
does it only happen after rain or high humidity
Reply With Quote
  #6  
Old 01-12-2013, 10:53 AM
kongo1 kongo1 is offline
New User
 
Join Date: Jan 2013
Posts: 5
kongo1 is starting off with a positive reputation.
I know the first time was after rain, but I can't remember if it rained the second time. However, it rained alot here in PA last night and the dealer called me last night and said they wanted to keep it over the weekend and try it again today or monday so hopefully they will find something if it is moisture related. It's just frustrating because I have seen several people write in to different sites with the exact issue but never see what the source of the problem is.
Reply With Quote
  #7  
Old 01-12-2013, 11:07 AM
greentree ford greentree ford is offline
Senior User
 
Join Date: Apr 2011
Posts: 322
greentree ford is gaining momentum as a positive member of FTE.greentree ford is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by kongo1 View Post
It's just frustrating because I have seen several people write in to different sites with the exact issue but never see what the source of the problem is.
Im going to jump on MADSONP's bane wagon.

Nobody ever reports back with the out come Please do everybody a favor and let us know what you find out, good or bad.

That is the only way that we learn whats up
Reply With Quote
  #8  
Old 01-12-2013, 11:10 AM
kongo1 kongo1 is offline
New User
 
Join Date: Jan 2013
Posts: 5
kongo1 is starting off with a positive reputation.
An example I found on another web site...

Hi, I got a 2008 Ford F-250 Gas truck. I left the keys in the igniton and in the run position overnight and now it wont start. All fuses and relays are good in both junction boxes. Battery has been replaced with a new one. When the key is turned to the ignition/on positon only the airbag light comes on. The instrument cluster is completely dead... it doesn't even light up when the parklights/headlights are turned on. Any ideas? PCM dead?
Reply With Quote
  #9  
Old 01-13-2013, 08:29 AM
kongo1 kongo1 is offline
New User
 
Join Date: Jan 2013
Posts: 5
kongo1 is starting off with a positive reputation.
In anyone's experience does this sound like it could be a PATS issue? Especially since the headlights and all other accesories (radio, heater, interior lights, locks, etc.) work fine, only the cluster doesn't illuminate, guages don't work, and won't start.
Reply With Quote
Old 01-13-2013, 08:29 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty

Tags
06, 450, airbag, light

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash Warning Lights exranger06 1978 - 1996 Big Bronco 2 05-09-2014 12:20 PM
airbag code 52 glemons42 1997 - 2003 F150 3 03-22-2014 11:56 AM
airbag question 97ranger xlt Ranger & B-Series 10 08-08-2013 01:03 PM
Airbag light 49 real_texan Explorer, Sport Trac, Mountaineer & Aviator 3 01-06-2013 11:05 AM
Airbag trouble code? fnx4wheeler Electrical Systems/Wiring 12 12-27-2012 07:50 AM



All times are GMT -5. The time now is 02:56 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup