Why are my plugs different? - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Why are my plugs different?

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-14-2012, 06:32 PM
giants17068 giants17068 is offline
New User
Thread Starter
 
Join Date: May 2012
Posts: 12
giants17068 is starting off with a positive reputation.
Why are my plugs different?

I recently discovered some disturbing info with my 2007 expy limited. I was expecting to have the long plugs that everyone has breaking off, however when I removed a plug it was a 5507 or NGK PZNAR6A11H. That seems awesome however everything I can find says these plugs are for a 2008 expy with brown boots. However, I have a 2007 with black boots?????? I have called ford and they have no record of my motor being swapped. So now what?? Thanks for any advice.
Reply With Quote
  #2  
Old 06-14-2012, 06:41 PM
chuck s chuck s is offline
Elder User
 
Join Date: Jan 2008
Location: Broadview Hts, Ohio
Posts: 512
chuck s is starting off with a positive reputation.
When was your '07 made?

-- Chuck
Reply With Quote
  #3  
Old 06-14-2012, 07:37 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Someone changed them for you. They come from the factory with Moto brand plugs.
Reply With Quote
  #4  
Old 06-15-2012, 06:42 AM
giants17068 giants17068 is offline
New User
Thread Starter
 
Join Date: May 2012
Posts: 12
giants17068 is starting off with a positive reputation.
I will look into the manufactured date, however i thought there was not a change until late in 08. I need to relearn myself on the vin code and get back to you. As for the plugs. They were moto sp509 plugs that came out and they had the NGK number on the bottom of them. That is what came out and what I put in.
Reply With Quote
  #5  
Old 06-15-2012, 04:58 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,132
berry1234 is gaining momentum as a positive member of FTE.
Call a ford dealer with your VIN. He can verify the correct plug. If it's running fine I wouldn't mess with it.
Reply With Quote
  #6  
Old 06-15-2012, 10:18 PM
dave91gt dave91gt is offline
Elder User
 
Join Date: Aug 2002
Location: Kenna,wv
Posts: 630
dave91gt is gaining momentum as a positive member of FTE.dave91gt is gaining momentum as a positive member of FTE.
NGK makes OEM Motorcraft plugs... Not sure about the Expy for application.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Own a 99 Expy thinking of buying a 2007+ rexpedition99 2007 - 2014 Expedition & Navigator 26 04-02-2014 07:53 PM
00 Expy Dreaded Misfire P303 6Fords 1997-2006 Expedition & Navigator 5 01-22-2014 07:32 PM
2007 Expy trailer lights not working joiseystud 2007 - 2014 Expedition & Navigator 7 09-18-2011 01:32 PM
Spark Plug Boots? jdboy Modular V8 (4.6L, 5.4L) 1 08-24-2010 07:40 PM
'01 Expy 5.4L new plug boots/springs? RAGaz 1997-2006 Expedition & Navigator 7 06-03-2007 01:11 PM


Go Back   Ford Truck Enthusiasts Forums >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 03:44 AM.