Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 1997 - 2003 F150
Sign in using an external account
Register Forgot Password?


1997 - 2003 F150 1997-2003 F150, 1997-1999 F250LD, 7700 & 2004 F150 Heritage SPONSORED BY:

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-30-2012, 02:03 AM
herb76 herb76 is offline
New User
 
Join Date: May 2012
Posts: 1
herb76 is starting off with a positive reputation.
2003 f-150 4.6l high idle at startup

i've got a 2003 ford f-150 with a 4.6l 150000 miles. when it is started the rpms are at 2000 for about a min. and a half then it drops to normal when its started cold. when started at opperating temp. the rpms are at 2000 for about 30 to 45 sec then drop to normal. the iac, upper and lower intake gaskets, intake run controler valve, dfbe, low intake and shield, coolant temp. sensor, intake air temp. sensor, egr, egr regulator valve, maf, ecm have all been swaped out no vacuum leaks all line in good condition tps voltage reading of 0.84v l'm at the end of my rope on this and ford has been no help
Reply With Quote
  #2  
Old 03-03-2013, 01:31 AM
daboot daboot is offline
New User
 
Join Date: Apr 2007
Posts: 20
daboot is starting off with a positive reputation.
Did u find a solution having the same problem
Reply With Quote
  #3  
Old 03-31-2013, 09:52 AM
Rednek Canuc Rednek Canuc is offline
New User
 
Join Date: Mar 2013
Posts: 6
Rednek Canuc is starting off with a positive reputation.
Jay Fkn Foisy
I'm not by any means tech swavy but had this happening to my 01 xlt pulled my air filter put in a k&n reusable air filter noticed some of the hoses attached to the intake were sliding off put them back in place they came loose again so used a couple hose clamps to keep them seated and sealed this rectified that issue hope that helps you out
Reply With Quote
Old 03-31-2013, 09:52 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 f150 4.6 high idle, ludging and hard shifting manchu76 Modular V8 (4.6L, 5.4L) 2 07-12-2013 03:05 AM
2000 F150 4.6l triton ghoota 1997 - 2003 F150 2 04-03-2013 10:36 PM
Need Help dal1969 1987 - 1996 F150 & Larger F-Series Trucks 2 06-17-2012 01:58 AM
High RPMs when coasting in neutral - Help ferchja 1997 - 2003 F150 3 04-19-2005 01:53 PM
rough idle and loss of power 2000 4.6 615chris Modular V8 (4.6L, 5.4L) 4 12-13-2003 09:12 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 1997 - 2003 F150

Tags
03, 2003, 46, 97, brakes, expedition, explorer, f150, fast, ford, high, idle, runs, start, startup, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 05:11 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup