Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-05-2012, 01:06 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Rough Idle?

Anyone have experience with a rough idle? Seems to be much worse with A/C on. Can feel it vibrate the steering wheel a bit. Fuel and air filter have been changed. Has 98K maybe time for spark plugs.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #2  
Old 04-05-2012, 01:54 PM
TCAS007's Avatar
TCAS007 TCAS007 is offline
Senior User
 
Join Date: May 2011
Location: Perry, Utah
Posts: 189
TCAS007 is starting off with a positive reputation.
Quote:
Originally Posted by berry1234 View Post
Anyone have experience with a rough idle? Seems to be much worse with A/C on. Can feel it vibrate the steering wheel a bit. Fuel and air filter have been changed. Has 98K maybe time for spark plugs.
Only had it on old cars where he spark plugs or coil packs failed. Or the MAF sensor.

Does it read an error code out?
Reply With Quote
  #3  
Old 04-05-2012, 01:55 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
No, no error code. It's not horrible, but I can feel the vibration for sure. If I raise the idle a bit it goes away.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
Old 04-05-2012, 01:55 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Tags
2005, classic, codesrough, erratic, explorer, fault, idle, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not idleing smooth. Al T 1973 - 1979 F-100 & Larger F-Series Trucks 1 04-08-2014 07:28 PM
2003 Windstar-rough idle when at a stop in drive. ryzl30 Arizona Chapter 2 01-28-2008 02:41 PM
Also Having A Rough Idle On 351M garypettengill 1973 - 1979 F-100 & Larger F-Series Trucks 3 12-11-2002 05:05 AM
rough idle and running on dvlinnell 1973 - 1979 F-100 & Larger F-Series Trucks 7 04-16-2002 11:29 PM
Rough idle matt davis Ford Inline Six, 200, 250, 4.9L / 300 2 02-15-2001 03:10 AM



All times are GMT -5. The time now is 07:04 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup