Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > 2011 & Newer Explorer
Sign in using an external account
Register Forgot Password?


2011 & Newer Explorer Discuss the all new redesigned Ford Explorer

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-01-2012, 01:42 PM
DeeDubz's Avatar
DeeDubz DeeDubz is offline
Junior User
 
Join Date: Jan 2012
Posts: 50
DeeDubz is starting off with a positive reputation.
2012 explorer.. not even a week old

Click the image to open in full size.
Yeah not very happy. We just bought it thursday... This morning my wife was on her way to work when the piece of plastic flew off at 65mph. We called ford and they told us " its not a problem to drive with out it " Any one else have this problem. My wife and I didnt really want to buy this vehicle in the first place... we needed a bigger vehicle. Now i get to go back to the dealer and fight with them if and when they are going to fix it.
Reply With Quote
  #2  
Old 04-01-2012, 03:54 PM
Buck 1 Buck 1 is offline
Posting Guru
 
Join Date: Oct 2005
Posts: 1,383
Buck 1 is a splendid one to beholdBuck 1 is a splendid one to beholdBuck 1 is a splendid one to beholdBuck 1 is a splendid one to beholdBuck 1 is a splendid one to beholdBuck 1 is a splendid one to beholdBuck 1 is a splendid one to behold
Should be no problem -- the dealer should be able to replace it right away. But why would you buy an Explorer when you state you need a bigger vehicle? Just curious.................
Reply With Quote
  #3  
Old 04-01-2012, 04:17 PM
DeeDubz's Avatar
DeeDubz DeeDubz is offline
Junior User
 
Join Date: Jan 2012
Posts: 50
DeeDubz is starting off with a positive reputation.
We had a Lexus and it was a little small for our family
Reply With Quote
  #4  
Old 04-02-2012, 08:31 PM
Green69 Green69 is offline
New User
 
Join Date: Dec 2011
Posts: 18
Green69 is starting off with a positive reputation.
New Explorer

Sorry about your problems with the new Explorer, I'm sure your dealer will promptly make right!
I have owned both a Rx350 and a Lexus Gx470, I honestly can say I enjoy the drive, ride and handling of the new Explorer much better! Not to mentioned the better gas mileage. I have a 6cyl. 4 WD , 4000 miles on it and now getting 19 mpg around town. Give it a chance, it is a terrific vehicle!
Reply With Quote
  #5  
Old 04-15-2012, 06:54 AM
tseekins's Avatar
tseekins tseekins is offline
Moderator
 
Join Date: Jan 2008
Location: Hampton, Virginia
Posts: 19,177
tseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputation
Soooooo, did the dealer make it right? I'm sure a piece had to be ordered as body parts aren't normally warehoused at the dealer.
__________________
Tim
SCPO United States Coast Guard Retired
2011 F-150 XLT 4x4 Ecoboost
2010 Ford Focus
2004 Expedition XLT 4x2

FTE Guidelines
Reply With Quote
  #6  
Old 04-15-2012, 07:22 AM
DeeDubz's Avatar
DeeDubz DeeDubz is offline
Junior User
 
Join Date: Jan 2012
Posts: 50
DeeDubz is starting off with a positive reputation.
the dealer took care of it. The part had to be ordered but we had it installed within a week. took them an hour.
Reply With Quote
  #7  
Old 04-30-2012, 07:37 PM
Trublufords Trublufords is offline
Senior User
 
Join Date: Apr 2004
Location: Central Va.
Posts: 443
Trublufords is starting off with a positive reputation.
What piece of plastic flew off???? Got a 12 and have had it a month and have put 5200 miles on it. We love it- 12 XLT 4x4 with tow package, 21-22 mpg highway! Regards Blue
Reply With Quote
  #8  
Old 04-30-2012, 09:49 PM
DeeDubz's Avatar
DeeDubz DeeDubz is offline
Junior User
 
Join Date: Jan 2012
Posts: 50
DeeDubz is starting off with a positive reputation.
Quote:
Originally Posted by Trublufords View Post
What piece of plastic flew off???? Got a 12 and have had it a month and have put 5200 miles on it. We love it- 12 XLT 4x4 with tow package, 21-22 mpg highway! Regards Blue
uh.... look at the photo.... a post. glad you love it... this car is a pos. Nothing compared to my F250.
Reply With Quote
  #9  
Old 05-01-2012, 05:26 AM
tseekins's Avatar
tseekins tseekins is offline
Moderator
 
Join Date: Jan 2008
Location: Hampton, Virginia
Posts: 19,177
tseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputationtseekins has a superb reputation
Quote:
Originally Posted by DeeDubz View Post
uh.... look at the photo.... a post. glad you love it... this car is a pos. Nothing compared to my F250.

Is it a POS just because a piece of plastic blew off? What else is going on that's making it so bad?
__________________
Tim
SCPO United States Coast Guard Retired
2011 F-150 XLT 4x4 Ecoboost
2010 Ford Focus
2004 Expedition XLT 4x2

FTE Guidelines
Reply With Quote
  #10  
Old 05-01-2012, 08:36 AM
DeeDubz's Avatar
DeeDubz DeeDubz is offline
Junior User
 
Join Date: Jan 2012
Posts: 50
DeeDubz is starting off with a positive reputation.
a post plastic flew off first week. Software recall after the first month. Yesterday whiling driving freeway speeds theres a notification " your near vehicles max speed... i was only going 60 and couldnt go over 65... none of the knuckle heads could help us over the phone so it sounds like i have to take the pos back to ford.
Reply With Quote
  #11  
Old 05-01-2012, 09:19 AM
2000silverbullet's Avatar
2000silverbullet 2000silverbullet is offline
Moderator
 
Join Date: Aug 2004
Location: Pittsburgh
Posts: 5,314
2000silverbullet is a splendid one to behold2000silverbullet is a splendid one to behold2000silverbullet is a splendid one to behold2000silverbullet is a splendid one to behold2000silverbullet is a splendid one to behold2000silverbullet is a splendid one to behold2000silverbullet is a splendid one to behold
Sounds like the MyKey is activated:

Additional MyKey features that can be programmed through the vehicle’s MyFord Touch menu:

Parental control of explicit radio programming
Limited top speed of 65, 70, 75 or 80 mph
Traction control system, which limits tire spin, cannot be deactivated
Limited audio volume to 44 percent of maximum
A speed alert chime at 45, 55 or 65 mph
__________________

Matt
2011 F350 - 6.2 CC, LB, 4.30s, Lariat Ultimate pkg, FX4, Amp steps, Lockpick, AC LC6i, JL HD900/5, JL 13TW5, JL C5-570's, Bilstein 7100 stabilizer, Rancho RS9000XL's, Leveled w/ 35" Toyo M/T's and 5 Star tuned
**Sold - 2000 F250 V10, 6.5" Pro Comp, 37" Toyo MT's
Reply With Quote
  #12  
Old 05-01-2012, 11:44 AM
kmonty2's Avatar
kmonty2 kmonty2 is offline
Posting Guru
 
Join Date: Dec 2010
Location: Sterling Heights, MI
Posts: 1,311
kmonty2 is gaining momentum as a positive member of FTE.kmonty2 is gaining momentum as a positive member of FTE.
kmonty
I have one too, my wife loves it. The software upgrade was needed and is free, I did mine myself. You must have activated the My Key which does allow you to limit the speed. Both of my cars have that feature and it is in the owners manual on how to use it, if you want to. Had mine in yesterday for cooling fan recal and the first oil change. Took about a hour to get both done. Seems like you bought a car you did not want to and are just complaining about little things that can go wrong with any vehicle you buy. Hopefully you have no more problems with the Explorer and it was just a fluke the plastic piece fell off.
__________________


Kevin
2011 F-250 CC, 6.2 Gas, 3.73, 4x4 w/FX4, Tuxedo Black, Steel Cloth interior,Goodyear Wrangler Duratrac's, Air Aid Intake, Bilstein 5100 shocks, Hellwig adjustable sway bar, 5 Star Tuned, Line X bed liner, X Tang Tri-Fold bed cover.
Reply With Quote
  #13  
Old 07-20-2012, 01:52 AM
enphluence enphluence is offline
Freshman User
 
Join Date: Nov 2009
Posts: 28
enphluence is starting off with a positive reputation.
Explorer

Gotta be careful of them closers at the dealership..lol

As for the speed thing...Sounds like the wifey doesnt want someone speeding. Look into the MYKey, a great feature. Just be glad she allowed you to listen to the radio.
Reply With Quote
  #14  
Old 12-10-2012, 06:37 PM
Sargemo105's Avatar
Sargemo105 Sargemo105 is offline
Senior User
 
Join Date: Feb 2011
Location: Minneapolis
Posts: 114
Sargemo105 is starting off with a positive reputation.
Update on an old thread. My wife bought a new 2011 Explorer that came with an annoying squeek. When we brought it into the dealership for other other minor issues or oil changes I would point it out, but they would never find the problem.

It continued to get worse, and I could only tell them it was on the passenger side front seat area, but I could not isolate its source. I also told them they needed to drive it on the freeway where it was more pronounced.

Alas, they finally located the problem....the black plastic exterior trim on the A-post. They replaced both sides and no more squeek!! In case anyone else is experiencing the same problem.
__________________
2011 F350 Super Duty: Lariet Crew Cab 4x4, 6.2 L, 3.73, Dark Blue/Sterling Grey, Black Leather Seats, Chrome/Lariet Interior/Tow package. After Market: DVD, Rust Proof, Paint Sealant, Tonneau Cover, Mud Flaps
Reply With Quote
Old 12-10-2012, 06:37 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Small Chassis Trucks > 2011 & Newer Explorer

Tags
2012, explorer, ford, mt, tires, toyo, trouble

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Crew Cab Project - The Long Journey 9thPony 1973 - 1979 F-100 & Larger F-Series Trucks 105 08-11-2014 07:22 PM
'12 edge tranny hesitation hillbilly1025 Crossovers 5 08-13-2013 07:52 AM
89 7.3 IDI - Not starting SAGA. Any ideas? DieselRugger Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 34 08-09-2013 05:37 PM
Back in the saddle .... rjent Bronco II 4 04-09-2013 09:05 PM
2012 Explorer's Sync montey2005 2011 & Newer Explorer 6 11-30-2012 11:18 PM



All times are GMT -5. The time now is 03:17 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup