Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Excursion - King of SUVs
Sign in using an external account
Register Forgot Password?


Excursion - King of SUVs 2000 - 2005 Ford Excursion

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-12-2012, 12:00 AM
UNLIMTD UNLIMTD is offline
New User
 
Join Date: Feb 2012
Posts: 12
UNLIMTD is starting off with a positive reputation.
04 Ex sudden loss of all engine power, sputter, then runs fine?

Hello all, I recently purchased a 2004 Diesel Excursion with 220,000 miles on it. I feel that I got a great deal and am headed into this knowing that I will be putting some money into it soon. I want to “Bulletproof” it, but I am hoping that can wait until next spring.

I changed the oil to Rotella T6 5-40, and used a product called Hot Shot’s Secret to help remove any “stiction” and cleanup the injectors.
I also changed both fuel filters and added the blue spring upgrade. I did not do the banjo bolts as they were not in stock.

**My problem:
Occasionally (4 times in 3 weeks) it will lose all engine power for a few seconds; this is while moving, and sometimes while accelerating. Today I was driving home from a 400 mile trip and halfway home it sputtered and came back to life a few seconds later. The cruise was on and it kept right on going, I did notice a large quantity of white smoke out of the exhaust. That did work well to clear some of the traffic around me, but not comforting. I was going a set speed on level ground, 75mph @ 2,200RPM.

**Supporting information:
The engine seems to have good power, and does not blow any smoke (normally).
It does stumble some when first driving it even after letting it warm up for 10 min. That does seem to be getting better, maybe just a placebo…
Fuel mileage is only about 16mpg. My previous 2004 Diesel Excursion was constantly 20mpg.
Stock tire size, and sagging springs for increased fuel mileage.

**Hypothesis
I have heard a lot about the FICM, and wondered if that was possibly the culprit.

Thank you all for your help as I have seen the wealth of information here and plan on adding to the knowledgebase when I am able.
Reply With Quote
  #2  
Old 03-12-2012, 12:32 AM
ddivinia ddivinia is offline
Senior User
 
Join Date: Aug 2009
Posts: 276
ddivinia is gaining momentum as a positive member of FTE.ddivinia is gaining momentum as a positive member of FTE.
Cam sensor?

My f-250 with th 7.3 had that issue. Would die going down the road, ec.

D.
Reply With Quote
  #3  
Old 03-12-2012, 12:47 AM
UNLIMTD UNLIMTD is offline
New User
 
Join Date: Feb 2012
Posts: 12
UNLIMTD is starting off with a positive reputation.
Cam sensor, interesting, would it immediately die, and them start up by itself again? Not that all of the symptoms would match, just looking for as much info as possible before I throw money at it.

I was thinking about the fuel pump, it would cause the symptoms I am seeing.
Reply With Quote
  #4  
Old 03-12-2012, 06:48 AM
cpoer's Avatar
cpoer cpoer is offline
Senior User
 
Join Date: May 2011
Location: Greensboro, NC
Posts: 104
cpoer is gaining momentum as a positive member of FTE.
Check the message "My Excursion is Hurt" on the front page today. Sounds like a very similar fuel pump issue.
__________________
2000 Ford Excursion 4x4 Limited 7.3 PSD. Edge Tuner, Rancho dual front shocks, Nitto Dura Grappler 305x55x20, KMC XD Diesel wheels, Warn Wrench and Lights, Road Armor Bumpers

Chris
Reply With Quote
  #5  
Old 03-12-2012, 09:34 AM
Toreador_Diesel's Avatar
Toreador_Diesel Toreador_Diesel is offline
Moderator
 
Join Date: Sep 2003
Location: Spring, Texas
Posts: 8,146
Toreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputation
Unless you have an AE, I would start with the usual suspects:

-You may have a leaky ICP sensor. If your truck is a late '04 truck this is something easy to diagnose. If you look on the passenger side valve cover, next to the GPCM (silver box with a black and green connector going to it), you should see a sensor with a pigtail going to it. Unplug this sensor and see if there is any oil coming up through it. If there is, replace the sensor and the harness. Drive the truck and see if the issue persists

-If you've noticed the truck having hard starts, idling rough, or not making power like it used to, you may want to test your FICM voltages to make sure it's not failing. http://www.ford-trucks.com/forums/89...procedure.html Make sure your batteries are also in good shape, a weak or dying battery can kill/damage a FICM.

The white smoke you're seeing is unburnt fuel due to the engine stopping and suddently catching itself, while not being able to burn that fuel. My educated guess would be the FICM or ICP.

If you have someone near your with one an AE it would make a world difference in getting this diagnosed and fixed. Riffraff Diesel: AutoEnginuity Total Ford Enhanced Bundle

Regardless, give the aforementioned a try and let us know what you come up with...
__________________
Excursion & 6.7 Forum Mod Death Row Inmate #21
Black Beauty: 2005 Ford Excursion Limited, 4wd "The 6.0" Bulletproofed by Powerstroke Enginuities Studded, Deleted, Flo-Pro'd, Atlas 40, Heavily RiffRaff'd, and Gearheaded
Big Red Beast: 2001 Ford Excursion Limited, 2wd, "The 7.3" Built with blood, sweat, and tears by Me and Riffraff Diesel, heavily modded, also Gearheaded
FTE Guidelines
Reply With Quote
  #6  
Old 03-12-2012, 07:47 PM
UNLIMTD UNLIMTD is offline
New User
 
Join Date: Feb 2012
Posts: 12
UNLIMTD is starting off with a positive reputation.
I had previously bought a Cheap Bluetooth OBDII tool and the torque app for my Android phone. I looked at it today and it had extended properties for a Powerstroke. I loaded them up and came up with this.

The FICM I believe is bad, 13~13.5 while driving, and it drops to 12 when starting.


FVP - 13.5
FPM - 49.0
FLP - 13.5
Reply With Quote
  #7  
Old 03-12-2012, 08:13 PM
Sader's Avatar
Sader Sader is offline
Senior User
 
Join Date: Nov 2008
Location: near mm217 off I-70 in MO
Posts: 306
Sader has a good reputation on FTE.Sader has a good reputation on FTE.
I'd say it's toast. Mine did the same thing.

__________________
2005 F250 PSD, C/C, 4x4, T/S, Lariat : 2000 Excursion PSD, 4x4, Limited, Large Edition, 200k club : 1996 Explorer Sport 4.0L OHV, 4x4, XLT
The strongest reason for the people to retain the right to keep and bear arms is, as a last resort, to protect themselves against tyranny in government.
Thomas Jefferson
Reply With Quote
  #8  
Old 03-12-2012, 08:21 PM
Toreador_Diesel's Avatar
Toreador_Diesel Toreador_Diesel is offline
Moderator
 
Join Date: Sep 2003
Location: Spring, Texas
Posts: 8,146
Toreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputation
you better replace that thing quick, fast, and in a hurry!

If you have the cash laying around, I'd look into swamps 58V FICM with a PHP FICM tune for better fuel economy and power.

hardRESET went through this same thing except his truck just wouldn't start: http://www.ford-trucks.com/forums/11...-problems.html

If you choose to stick with the stocker you could go to FICM Repair.com - Your Source for FICM Repair
__________________
Excursion & 6.7 Forum Mod Death Row Inmate #21
Black Beauty: 2005 Ford Excursion Limited, 4wd "The 6.0" Bulletproofed by Powerstroke Enginuities Studded, Deleted, Flo-Pro'd, Atlas 40, Heavily RiffRaff'd, and Gearheaded
Big Red Beast: 2001 Ford Excursion Limited, 2wd, "The 7.3" Built with blood, sweat, and tears by Me and Riffraff Diesel, heavily modded, also Gearheaded
FTE Guidelines
Reply With Quote
  #9  
Old 03-12-2012, 08:21 PM
Toreador_Diesel's Avatar
Toreador_Diesel Toreador_Diesel is offline
Moderator
 
Join Date: Sep 2003
Location: Spring, Texas
Posts: 8,146
Toreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputation
you better replace that thing quick, fast, and in a hurry!

If you have the cash laying around, I'd look into swamps 58V FICM with a PHP FICM tune for better fuel economy and power.

hardRESET went through this same thing except his truck just wouldn't start: http://www.ford-trucks.com/forums/11...-problems.html

If you choose to stick with the stocker you could go to FICM Repair.com - Your Source for FICM Repair
__________________
Excursion & 6.7 Forum Mod Death Row Inmate #21
Black Beauty: 2005 Ford Excursion Limited, 4wd "The 6.0" Bulletproofed by Powerstroke Enginuities Studded, Deleted, Flo-Pro'd, Atlas 40, Heavily RiffRaff'd, and Gearheaded
Big Red Beast: 2001 Ford Excursion Limited, 2wd, "The 7.3" Built with blood, sweat, and tears by Me and Riffraff Diesel, heavily modded, also Gearheaded
FTE Guidelines
Reply With Quote
  #10  
Old 03-13-2012, 10:42 PM
UNLIMTD UNLIMTD is offline
New User
 
Join Date: Feb 2012
Posts: 12
UNLIMTD is starting off with a positive reputation.
Well I misunderstood the voltage readings I was seeing.


I thought that might be the case so I followed the procedure to test with a multimeter today. The FICM should be fine, it only dipped to 48 when it was cranking and then went up to 49 and stayed there.


I will check the ICP.


While I was in there I found this wire that has an end on it, but nothing connected to it. I looked around and did not see anything that it would go to. Any ideas as to what it would connect to?
Attached Images
 
Reply With Quote
  #11  
Old 03-13-2012, 11:03 PM
UNLIMTD UNLIMTD is offline
New User
 
Join Date: Feb 2012
Posts: 12
UNLIMTD is starting off with a positive reputation.
I checked the ICP(please verify that is the ICP in the picture)it was clean and dry.
Attached Images
 
Reply With Quote
  #12  
Old 03-14-2012, 12:30 AM
UNLIMTD UNLIMTD is offline
New User
 
Join Date: Feb 2012
Posts: 12
UNLIMTD is starting off with a positive reputation.
I pulled the EGR, and found it was a complete mess. Not dry and sooty like it should be, is this an indicator of the oil cooler leaking?


I cleaned it up as best I could, vacuumed out the hole and re-installed it.
Attached Images
    
Reply With Quote
  #13  
Old 03-14-2012, 08:06 AM
Toreador_Diesel's Avatar
Toreador_Diesel Toreador_Diesel is offline
Moderator
 
Join Date: Sep 2003
Location: Spring, Texas
Posts: 8,146
Toreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputation
GOOD GOD!!!!

That thing is NASTY!

If I'm not mistaken, that looks like the early signs of the EGR cooler leaking due to the oil cooler slowly but surely clogging.

Does your truck spend time idling?
__________________
Excursion & 6.7 Forum Mod Death Row Inmate #21
Black Beauty: 2005 Ford Excursion Limited, 4wd "The 6.0" Bulletproofed by Powerstroke Enginuities Studded, Deleted, Flo-Pro'd, Atlas 40, Heavily RiffRaff'd, and Gearheaded
Big Red Beast: 2001 Ford Excursion Limited, 2wd, "The 7.3" Built with blood, sweat, and tears by Me and Riffraff Diesel, heavily modded, also Gearheaded
FTE Guidelines
Reply With Quote
  #14  
Old 03-14-2012, 09:31 AM
UNLIMTD UNLIMTD is offline
New User
 
Join Date: Feb 2012
Posts: 12
UNLIMTD is starting off with a positive reputation.
I just bought this Excursion about a month ago. I don’t have any history; I do let it warm up for about 10 min in the mornings. I expect that you are referring to much longer idling than that. I do see some oil in the valley, on what I believe is the oil cooler. I knew that before I bought it, but like I said in the original post, I felt I got it for a good price and expect to put a new Oil Cooler, EGR Cooler, Studs, and Head gaskets on it. I was hoping that it would not be too soon.
As far as I am aware I do not have any signs of head gasket issues yet. Maybe I should just do the Oil Cooler and EGR Cooler. This is more of a long term concern, and I am hoping it can wait until summer.
This engine does have 220,000 miles on it.
Any idea on the wire that is just dangling there?
Reply With Quote
  #15  
Old 03-14-2012, 11:15 AM
Toreador_Diesel's Avatar
Toreador_Diesel Toreador_Diesel is offline
Moderator
 
Join Date: Sep 2003
Location: Spring, Texas
Posts: 8,146
Toreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputationToreador_Diesel has a superb reputation
No clue on that wire, still trying to figure it out myself...

From the looks of things, you're ok....for now; but the clock is ticking...
__________________
Excursion & 6.7 Forum Mod Death Row Inmate #21
Black Beauty: 2005 Ford Excursion Limited, 4wd "The 6.0" Bulletproofed by Powerstroke Enginuities Studded, Deleted, Flo-Pro'd, Atlas 40, Heavily RiffRaff'd, and Gearheaded
Big Red Beast: 2001 Ford Excursion Limited, 2wd, "The 7.3" Built with blood, sweat, and tears by Me and Riffraff Diesel, heavily modded, also Gearheaded
FTE Guidelines
Reply With Quote
Old 03-14-2012, 11:15 AM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Excursion - King of SUVs

Tags
97, 99, car, dying, engine, expedition, greensboro, loss, power, powered, smoke, sputtering, sudden, support, tech, upgrade, vbulletin, white

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
7.3 smog 7995fordguy 1999 - 2003 7.3L Power Stroke Diesel 69 11-15-2013 05:00 AM
7.3 Help ideas smog 7995fordguy Super Duty & Heavy Duty 3 10-25-2013 05:06 AM
2005 f150 intermittent sputtering while driving zzyzxroad 2004 - 2008 F150 21 01-24-2012 07:18 PM



All times are GMT -5. The time now is 01:39 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup