Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-17-2012, 10:57 AM
scholzee scholzee is offline
Senior User
 
Join Date: Mar 2004
Location: Grand Island, NY
Posts: 219
scholzee is starting off with a positive reputation.
RSC squiggle vehicle icon on message center random

2008 Expediton Limited 4x4 59k miles. The rsc squiggle vehicle in message center has been staying on for awhile at random times. It happens at fast and slow speeds on dry roads, straight line, i do not think the system is activating I think its telling me a fault. Its at the Ford dealer and they say its a sensor in the steering wheel causing it, we rarely ever use the tilt function on the steering wheel. They are charging $230 parts and labor to fix it, I said go ahead, anyone else have this problem ? Thanks for all replies !!
Reply With Quote
  #2  
Old 02-18-2012, 10:53 AM
scholzee scholzee is offline
Senior User
 
Join Date: Mar 2004
Location: Grand Island, NY
Posts: 219
scholzee is starting off with a positive reputation.
Just got the Expedition from dealer. they replaced steering wheel rotation sensor and calibrated it. Sensor 9L1Z-3F818-A $36.00 and &176.00 labor. I asked for the old part and its all plastic and looks like one mounting ear was cracked not sure if that was from removal or like that from the factory. It looks to be u shaped and and a disc must travel inside the u. Thw disc must have slots in it, the u looks to have a led light on one side and detector on the other. It must count pulses as light passes through slots and is blocked where there are no slots. I'll give an updated in a week or so to see if problem is fixed.
Reply With Quote
Old 02-18-2012, 10:53 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
RSC icon on at random times....help ecyrbh 2007 - 2014 Expedition & Navigator 6 06-14-2014 12:14 PM
glow plug resistor 88beast Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 0 12-14-2013 08:25 AM
ABS RSC Warning Light Power Stroke 7107 Explorer, Sport Trac, Mountaineer & Aviator 2 09-14-2009 07:22 AM
RSC and traction control moonunit7317 2007 - 2014 Expedition & Navigator 41 01-26-2008 09:33 PM
RSC and traction control moonunit7317 2007 - 2014 Expedition & Navigator 0 11-27-2007 07:24 PM


Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Tags
07, 2008, calibrate, expedition, explorer, ford, forums, icon, light, lincoln, navigator, problems, rsc, squiggle, vehicle

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 12:55 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup