Need a picture of a part, I have the number - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Need a picture of a part, I have the number

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-28-2012, 02:32 PM
cop on my back's Avatar
cop on my back cop on my back is offline
Freshman User
Thread Starter
 
Join Date: Feb 2011
Posts: 35
cop on my back is starting off with a positive reputation.
Need a picture of a part, I have the number

I had my 08 looked at by the dealer and I need part #7L1Z 14C724 B This is a seat heater/motor. Thing is, it doesn't match the numbers on my heater motor or control box that is under the seat. Any Ford guys out there with access to a part diagram? I have googled the number and get close, but no pics.
Reply With Quote
  #2  
Old 01-28-2012, 03:36 PM
cop on my back's Avatar
cop on my back cop on my back is offline
Freshman User
Thread Starter
 
Join Date: Feb 2011
Posts: 35
cop on my back is starting off with a positive reputation.
After more research, it would appear this is the lower fan assembly. I think the heating element is toast.
Reply With Quote
  #3  
Old 01-29-2012, 10:05 AM
RI-Matt's Avatar
RI-Matt RI-Matt is offline
Senior User
 
Join Date: Mar 2004
Posts: 370
RI-Matt is starting off with a positive reputation.
Try this.

Front Seat Pads/Valances & Heating, 2007/From: 08/02/2006; With Bucket Front Seats, With Temp Control Passenger Seat, With Temp Control Drivers Seat

There is an upper and lower heater fan assembly.The part number you gave is just the lower.
BUT.......
There is a control module also, part #9U5Z-14C724-B (old part # 7L1Z-14C724-C ) so it get confusing on what part you need.

What numbers are on the part in the vehicle or going by the diagram what part do you need?

Matt
Reply With Quote
  #4  
Old 01-29-2012, 10:33 AM
cop on my back's Avatar
cop on my back cop on my back is offline
Freshman User
Thread Starter
 
Join Date: Feb 2011
Posts: 35
cop on my back is starting off with a positive reputation.
Thanks for that. The dealer specified that number. I took the seat apart and ran the heating and cooling with the fan assemblies loose and the lower one does not produce heat. Although they only work for about 15 seconds, the upper one does produce heat.

I think the cause was the fact there is no air filter on the lower one and there was lint in the heating/cooling element. Judging by the discolouration I would say the element got too hot due to the lack of air movement and got damaged.

I contacted the manufacturer, Amerigon, to see if I can just get the Thermal-electric device and solder it in myself. I don't expect that will work as they have produced over 14,000,000 of these and my little request for one will be so far off the radar it would be a cold day in hell before I got it.

I will likely get one from a dealer in the States as they are way expensive up here in Canada.
Reply With Quote
  #5  
Old 01-29-2012, 05:52 PM
RI-Matt's Avatar
RI-Matt RI-Matt is offline
Senior User
 
Join Date: Mar 2004
Posts: 370
RI-Matt is starting off with a positive reputation.
You say it only stays on for 15 seconds? Does the passenger side heat work? Both top and bottom ? Just a thought but have you tried switching the module PS to DS ?

Matt
Reply With Quote
  #6  
Old 01-29-2012, 05:58 PM
cop on my back's Avatar
cop on my back cop on my back is offline
Freshman User
Thread Starter
 
Join Date: Feb 2011
Posts: 35
cop on my back is starting off with a positive reputation.
Yes, stays on for about 15 seconds and then when you try to turn it back on the indicator lights blip for just a split second and won't stay on. If you cycle the key off and on again you can turn it back on for another 15 seconds and it repeats. This appears to be the way they all do when they fail from what I have read.

During that 15 seconds the upper unit produces heat, the lower does not. Again, with the discolouration in the element in the lower unit I suspect that is the problem. I have not tried to swap out the driver's side, don't feel like undoing another seat if I don't have to. Besides, when the dealer ran a diagnostic on the system it pointed to the passenger side lower fan assembly unit.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2015 TED unit replacement andpart umber? Amelio 6.7L Power Stroke Diesel 21 11-22-2016 04:57 PM
Looking for some part availabilty or part numbers for a heater hose assembly LIGOOMBA Pre-Power Stroke Diesel (7.3L IDI & 6.9L) 26 05-18-2012 07:23 PM
seat heater element part # and disassembly fordboy2 1999 to 2016 Super Duty 4 03-07-2008 11:06 AM
6V to 12V Heater Motor ? restoringmy46 1948 - 1956 F1, F100 & Larger F-Series Trucks 5 04-17-2007 12:58 AM
Blower motor part number ID help irondragon79 1948 - 1956 F1, F100 & Larger F-Series Trucks 3 10-20-2005 01:39 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
14c724, 7l1z, 7l1z14c724b, 9u5z14c724b, ford, number, picture, trucks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 09:37 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.