randomly shuts off when driving - Page 3 - Ford Truck Enthusiasts Forums



Pre-Power Stroke Diesel (7.3L IDI & 6.9L) Diesel Topics Only

randomly shuts off when driving

Reply
 
 
 
Thread Tools Search this Thread
  #31  
Old 01-27-2012, 12:19 PM
eatont9999's Avatar
eatont9999 eatont9999 is offline
Posting Guru
 
Join Date: Dec 2010
Location: Dallas, TX
Posts: 2,034
eatont9999 is starting off with a positive reputation.
I replaced the ignition switch yesterday evening. It needed it badly. I tried to remove the wiring harness and with barely any force, the entire plastic part came off with the harness. All is working beautifully now. I even have key-back accessory now! I'll post carnage pictures later.
Reply With Quote
  #32  
Old 12-04-2012, 06:34 PM
snoop snoop is offline
New User
 
Join Date: Dec 2012
Posts: 10
snoop is starting off with a positive reputation.
I have an 06 6.0. replaced ficm, replaced cam shaft sensor, still keeps shutting off at random times, any suggestions. im new here ,so sorry if im cutting in. ty in advance
Reply With Quote
  #33  
Old 12-04-2012, 06:57 PM
tecgod13 tecgod13 is offline
Postmaster
 
Join Date: Sep 2007
Location: Western Mass
Posts: 2,943
tecgod13 is gaining momentum as a positive member of FTE.tecgod13 is gaining momentum as a positive member of FTE.
Try posting this in the 6.0 forum.

This is the IDI as in OLD engines... the best suggestion any of us have with a 6.0 is to get rid of it and buy an old IDI
Reply With Quote
  #34  
Old 12-04-2015, 10:54 AM
madmat madmat is offline
New User
 
Join Date: Dec 2015
Posts: 1
madmat is starting off with a positive reputation.
problems

as far as your random cutoff on the powerstroke its the crank position sensor on the front cover 20 something dollars from ford and fixed
Reply With Quote
  #35  
Old 12-04-2015, 11:01 AM
sjwelds's Avatar
sjwelds sjwelds is online now
Elder User
 
Join Date: May 2009
Location: Inman KS
Posts: 582
sjwelds is starting off with a positive reputation.
Wrong forum anyhow.
Reply With Quote
  #36  
Old 12-04-2015, 11:34 AM
madpogue madpogue is offline
Post Fiend
 
Join Date: Oct 2003
Location: Madison, WI
Posts: 6,996
madpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to beholdmadpogue is a splendid one to behold
^^^^ Not to mention reference to a non-existent part.....
Reply With Quote
  #37  
Old 12-04-2015, 11:56 AM
sjwelds's Avatar
sjwelds sjwelds is online now
Elder User
 
Join Date: May 2009
Location: Inman KS
Posts: 582
sjwelds is starting off with a positive reputation.
^^^ So many sensors, so little time....
Reply With Quote
  #38  
Old 12-04-2015, 02:21 PM
tankguy tankguy is offline
Junior User
 
Join Date: Sep 2015
Posts: 63
tankguy is starting off with a positive reputation.
PS's are known for the cam positioning sensor causing issues. Most tow truck drivers carry spare in the glove box.


Gotta love those sensors...
Reply With Quote
  #39  
Old 12-04-2015, 10:11 PM
Macrobb's Avatar
Macrobb Macrobb is offline
Postmaster
 
Join Date: Dec 2011
Posts: 3,156
Macrobb is gaining momentum as a positive member of FTE.
Yet another reason to have an IDI!

(To be fair, though... My mom's 7.3 PS has 365K miles on it with the original cam position sensor, 7 original injectors, and still runs OK)
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 Fuel Pump Troubleshooting (intermittantly dies) cokeman Modular V10 (6.8l) 17 04-29-2016 09:38 PM
Strange random no start. TheBlueMule 6.0L Power Stroke Diesel 7 04-02-2016 08:31 AM
'93 Ranger self test vintagequest Ranger & B-Series 4 01-09-2016 05:53 PM
Overheating coil? Dave145 1973 - 1979 F-100 & Larger F-Series Trucks 101 03-24-2014 04:21 PM
2005, Engine Dies MWC 1997-2006 Expedition & Navigator 9 11-01-2013 07:17 AM


Go Back   Ford Truck Enthusiasts Forums >

Tags
150, 1979, 2008, 73, 93, driving, ecoboost, f150, f250, ford, fuel, idi, im, shut, shuts, solenoid

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 08:53 AM.