Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-21-2011, 10:52 PM
jake00's Avatar
jake00 jake00 is offline
FTE is my crack
 
Join Date: Apr 2004
Location: NW burbs of chicago
Posts: 13,496
jake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant future
rear roof heat??? URGENT

Hey guys, thanks for the help, We're leaving on a trip at 10 am...


the manual shows the "rear controls" as 2 ***** that the left one is the fan level the right one is the "roof/all/floor" control.....

But, in my expy the right **** is a temp ****... heat (twisted clockwise directs it to the floor) cool (twisted counter clockwise directs it to the roof)

Can I get heat to come out of the roof?
__________________
Past rides
06 F250 CC v10 4x4 Lariat bought 5/08 for 20k sold 10/10 for 20K.
RIP BIG GREEN owned her from 08.17.04 - 05.10.08
Reply With Quote
  #2  
Old 12-22-2011, 01:34 AM
Tylus's Avatar
Tylus Tylus is offline
MMNC (SS)
 
Join Date: Mar 2004
Location: Pearl Harbor
Posts: 10,518
Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.
yes you can

you should have 2 ***** on the rear of the center console. 1 **** is the temp selector, the other **** is the fan speed. It will blow ambient temp air, or heat out the roof unless you turn on the Rear A/C on the dash.

on my Expy the Hot and/or cold comes out under the drivers/passenger front seats, and it comes out from the top vents.
__________________
2002 Excursion XLT w/ V-10 <---Build thread
2015 Chevrolet Tahoe - I've owned 4 brand new Fords since 2006. Notice that I bought a Chevy this time. That should tell you something
Reply With Quote
  #3  
Old 12-22-2011, 10:40 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
Note, I have found if you peg the hear to 90 on the front controls it will not blow out the rear top vents. I guess it doesn't want to 'scald' the people with the hot air. Move it to 85 and it seems to work fine.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #4  
Old 12-30-2011, 10:03 AM
cstanley44's Avatar
cstanley44 cstanley44 is offline
Junior User
 
Join Date: Jun 2011
Location: Orlando, FL
Posts: 87
cstanley44 is gaining momentum as a positive member of FTE.
I dont get any air moment from the rear roof vents when the heat is on.
AC blows cold.

When I switch to HOT, I can still hear the blower out back, but no air comes out.

Must have a stuck vent flapper or something.
Reply With Quote
  #5  
Old 12-30-2011, 10:29 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
I would say so. Work the vent controls with the front set to Rear so that the rear controls work. Maybe you can unstick them. listen for the motor trying to move vents.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #6  
Old 01-01-2012, 10:04 PM
jake00's Avatar
jake00 jake00 is offline
FTE is my crack
 
Join Date: Apr 2004
Location: NW burbs of chicago
Posts: 13,496
jake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant futurejake00 has a brilliant future
I can't get heat out of the rear roof by using the rear controls
__________________
Past rides
06 F250 CC v10 4x4 Lariat bought 5/08 for 20k sold 10/10 for 20K.
RIP BIG GREEN owned her from 08.17.04 - 05.10.08
Reply With Quote
  #7  
Old 01-02-2012, 12:32 PM
chuck s chuck s is offline
Elder User
 
Join Date: Jan 2008
Location: Broadview Hts, Ohio
Posts: 512
chuck s is starting off with a positive reputation.
In the rear heat comes out the floor vents, AC or outside air out of the ceiling. At least on mine. As I would expect. Depends on the temperature setting.

-- Chuck
Reply With Quote
  #8  
Old 01-05-2012, 03:36 PM
Blacknav Blacknav is offline
Junior User
 
Join Date: Mar 2008
Posts: 57
Blacknav is starting off with a positive reputation.
Quote:
Originally Posted by chuck s View Post
In the rear heat comes out the floor vents, AC or outside air out of the ceiling. At least on mine. As I would expect. Depends on the temperature setting.

-- Chuck
^ Is that normal? I've been racking my brains cause I can't get hot air to blow out of the roof vents.

If I set the controls to cold it blows out fine from the roof, but if I set it to hot the roof vents turn off and it blows hot air from the floor vent in teh third row.

I've left the temp setting in the middle to get a bit of warmth from the top vents.

Never really noticed it until recently so I always thought something was wrong, but now I'm not so sure
Reply With Quote
  #9  
Old 01-05-2012, 03:54 PM
cstanley44's Avatar
cstanley44 cstanley44 is offline
Junior User
 
Join Date: Jun 2011
Location: Orlando, FL
Posts: 87
cstanley44 is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by Blacknav View Post
^ Is that normal? I've been racking my brains cause I can't get hot air to blow out of the roof vents.

If I set the controls to cold it blows out fine from the roof, but if I set it to hot the roof vents turn off and it blows hot air from the floor vent in teh third row.

I've left the temp setting in the middle to get a bit of warmth from the top vents.

Never really noticed it until recently so I always thought something was wrong, but now I'm not so sure

Who knew!
I have the same functionality as you, thought for sure heat should blow out of the roof, but I guess not.
Reply With Quote
  #10  
Old 01-06-2012, 10:19 PM
mtondreo mtondreo is offline
Senior User
 
Join Date: Jan 2005
Location: Pinellas Park, FL
Posts: 414
mtondreo is gaining momentum as a positive member of FTE.
Was kind of following this. Apparently this is different on the 3rd gens. My 06, I can crank the heat all the way over and it will still blow from the roof or wherever I tell it to. I have not payed attention on the 3rd gens to see if they have gone to a more automatic system-but I can definitely crank the heat through the roof in mine. I verified this morning just to be sure.
__________________
2013 F150 FX2 5.0 Screw, 401a, 3.55 ELD-that is all
2011 Expedition XLT 202package-superchips cortex
2006 Expedition EB 4x4 (you served us well)
previous 2003 F150 Supercrew (love the Expy, but still missed, if only you were 4x4)
1987 Ranger 4x4 (RIP)
Reply With Quote
  #11  
Old 01-09-2012, 02:03 PM
Blacknav Blacknav is offline
Junior User
 
Join Date: Mar 2008
Posts: 57
Blacknav is starting off with a positive reputation.
Quote:
Originally Posted by mtondreo View Post
Was kind of following this. Apparently this is different on the 3rd gens. My 06, I can crank the heat all the way over and it will still blow from the roof or wherever I tell it to. I have not payed attention on the 3rd gens to see if they have gone to a more automatic system-but I can definitely crank the heat through the roof in mine. I verified this morning just to be sure.
Yea, I had a 98 Navi before and it would just do what I told it. Which is why I assumed somethign was wrong when my '07 didn't do the same thing.

Glad I didn't pay ford to diagnose and charge me to tell me that,
Reply With Quote
  #12  
Old 01-09-2012, 11:14 PM
Tylus's Avatar
Tylus Tylus is offline
MMNC (SS)
 
Join Date: Mar 2004
Location: Pearl Harbor
Posts: 10,518
Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.Tylus has a spectacular reputation.
weird, maybe mine is screwed up?

I've definately gotten hot air out the top before....granted it doesn't get used a ton out here, so I really don't care. Long as the A/C works properly
__________________
2002 Excursion XLT w/ V-10 <---Build thread
2015 Chevrolet Tahoe - I've owned 4 brand new Fords since 2006. Notice that I bought a Chevy this time. That should tell you something
Reply With Quote
Old 01-09-2012, 11:14 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2008, 2012, air, dont, expadition, expedition, ford, heat, hot, make, navigator, rear, roof, top, truck, vents

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 07:11 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup