Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Ford V6 > 3.0L V6
Sign in using an external account
Register Forgot Password?


Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-11-2011, 01:59 PM
State_Tweaker State_Tweaker is offline
New User
 
Join Date: Aug 2003
Location: Spartanburg
Posts: 19
State_Tweaker is starting off with a positive reputation.
Tommy Peake
PO301 Help Tracking Down

2001 Ranger 3.0 XLT non-flex fuel.
PO301 (Misfire #1) still popping up. Ignition Wire check good. So it is either the injector or compression. CEL comes on, but ocassionally goes away once in awhile for about 10 minutes.

Rough idle on start up, especially when cold.
Runs okay down the highway, but feel a slight loss in power
Put seafoam in the tank the last 3 refills
Oil is being consumers at about 1 quart every 2.5 weeks (500 miles)
No smoke that I can see
No smells except a hot oil smell on passenger side (same as cylinder 1) when I lean down to get stuff out of the floor board.

Haven't performed a compression test, but have read about the valves receding into head. If that is the case is the solution to replace the head or valves or both?

What do you folks think, and am I going down the right path?
Reply With Quote
Old 12-11-2011, 01:59 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Ford V6 > 3.0L V6

Tags
03, 2001, 30, 301, code, codes, explorer, f150, ford, misfire, po, po301, ranger, v6, warm

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to clean a Mass Air Flow (MAF) sensor - 5.4L CelticDevilDog 2004 - 2008 F150 16 08-30-2014 11:42 PM
2003 Expedition trouble codes PO301 and PO316 ltramon45 Expedition & Navigator 1 08-21-2013 02:07 PM
codes 95schauf 1994.5 - 1997 7.3L Power Stroke Diesel 3 10-08-2012 10:01 AM
PO 301 Code, Cylinder 1 Misfire bowdog 1997 - 2003 F150 8 02-07-2008 10:13 AM
compression 86 f250? jriley301 1980 - 1986 Bullnose F100, F150 & Larger F-Series Trucks 0 09-19-2004 10:42 PM



All times are GMT -5. The time now is 07:16 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup