DRIVE TO CLEAN EXHAUST FILTER - Ford Truck Enthusiasts Forums



6.4L Power Stroke Diesel Engine fitted to 2008 - 2010 F250, F350 and F450 pickup trucks and F350 + Cab Chassis SPONSORED BY:

DRIVE TO CLEAN EXHAUST FILTER

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-02-2011, 06:30 PM
ljutic ss's Avatar
ljutic ss ljutic ss is offline
Posting Guru
Thread Starter
 
Join Date: Apr 2008
Location: Green Lane, Pa.
Posts: 2,392
ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.
DRIVE TO CLEAN EXHAUST FILTER

I got the latest flash back in July and that's when the cleaning message would only come on for a few seconds and then disappear. Today for the 1st time in a dozen or more regens since the last re-flash the message comes on "drive to clean exhaust filter and stayed on for maybe 5-6 miles, then the display changed to "cleaning exhaust filter" and stayed on for the final 10-12 miles, then displayed exhaust filter cleaning completed. Seems like my latest re-flash got corrupted somehow.
Reply With Quote
  #2  
Old 12-02-2011, 07:25 PM
slowmans's Avatar
slowmans slowmans is offline
Postmaster
 
Join Date: Jan 2006
Posts: 2,686
slowmans has a good reputation on FTE.slowmans has a good reputation on FTE.
The "drive to clean" only comes on when it senses it really needs to be cleaned....maybe you got some bad fuel?
Reply With Quote
  #3  
Old 12-02-2011, 07:32 PM
senix's Avatar
senix senix is online now
Moderator
 
Join Date: Aug 2008
Location: Frederick, MD
Posts: 26,422
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
nope..that sequence is correct. Happens to me sometimes when I am towing heavy up hills.
Reply With Quote
  #4  
Old 12-02-2011, 07:58 PM
ljutic ss's Avatar
ljutic ss ljutic ss is offline
Posting Guru
Thread Starter
 
Join Date: Apr 2008
Location: Green Lane, Pa.
Posts: 2,392
ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.
Quote:
Originally Posted by senix View Post
nope..that sequence is correct. Happens to me sometimes when I am towing heavy up hills.

Do you have the latest flash that suppose to do away with the message staying on more then just a few seconds?
Reply With Quote
  #5  
Old 12-02-2011, 08:04 PM
senix's Avatar
senix senix is online now
Moderator
 
Join Date: Aug 2008
Location: Frederick, MD
Posts: 26,422
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
Yes. I got the 11B23 in July.
Reply With Quote
  #6  
Old 12-02-2011, 08:18 PM
ljutic ss's Avatar
ljutic ss ljutic ss is offline
Posting Guru
Thread Starter
 
Join Date: Apr 2008
Location: Green Lane, Pa.
Posts: 2,392
ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.
So the original question is, does the latest flash do away with the cleaning filter message after a few seconds, or does it stay on for the full course of the clean?
Reply With Quote
  #7  
Old 12-02-2011, 08:22 PM
senix's Avatar
senix senix is online now
Moderator
 
Join Date: Aug 2008
Location: Frederick, MD
Posts: 26,422
senix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputationsenix has a superb reputation
The message does disappear except in limited circumstances where you get the "Drive to clean" message.
Reply With Quote
  #8  
Old 12-02-2011, 08:30 PM
ljutic ss's Avatar
ljutic ss ljutic ss is offline
Posting Guru
Thread Starter
 
Join Date: Apr 2008
Location: Green Lane, Pa.
Posts: 2,392
ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.ljutic ss has a great reputation on FTE.
Quote:
Originally Posted by senix View Post
The message does disappear except in limited circumstances where you get the "Drive to clean" message.

OK thanks, today's cleaning cycle was the 1st in 4,000 miles since the last time it stayed on for the entire clean.
Reply With Quote
  #9  
Old 12-02-2011, 08:40 PM
bnmccoy's Avatar
bnmccoy bnmccoy is offline
Elder User
 
Join Date: Aug 2004
Location: Edmond, OK
Posts: 932
bnmccoy is gaining momentum as a positive member of FTE.bnmccoy is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by senix View Post
nope..that sequence is correct. Happens to me sometimes when I am towing heavy up hills.
Same here. I don't get it solo; but I have gotten same sequence when towing heavy (but no big hills) but Interstate speeds...... surprised me too. I do not have the very latest flash but have the first one they mailed the letter for......

It wasn't like it had not had a chance to clean as I had already been on Interstate for some time; and it stayed on. Has happened at least twice towing.

Bob
Reply With Quote
  #10  
Old 12-02-2011, 08:42 PM
galaxie641 galaxie641 is offline
Postmaster
 
Join Date: Nov 2006
Location: SE Wyoming
Posts: 4,521
galaxie641 has a very good reputation on FTE.galaxie641 has a very good reputation on FTE.galaxie641 has a very good reputation on FTE.galaxie641 has a very good reputation on FTE.
From what I have seen you will get that message if you have cut your previous regen short a few times. I've had it happen twice with the new flash and each time I knew I was cutting it short before hand.
Reply With Quote
  #11  
Old 12-02-2011, 09:02 PM
Softballdad's Avatar
Softballdad Softballdad is offline
Senior User
 
Join Date: Mar 2008
Location: Chesapeake, Va
Posts: 125
Softballdad is starting off with a positive reputation.
I've got the latest flash, and my "cleaning exhaust filter" message stays on every regen cycle.
Reply With Quote
  #12  
Old 12-02-2011, 09:04 PM
slowmans's Avatar
slowmans slowmans is offline
Postmaster
 
Join Date: Jan 2006
Posts: 2,686
slowmans has a good reputation on FTE.slowmans has a good reputation on FTE.
Quote:
Originally Posted by Softballdad View Post
I've got the latest flash, and my "cleaning exhaust filter" message stays on every regen cycle.
I would say you may not have the latest flash......
Reply With Quote
  #13  
Old 12-02-2011, 09:15 PM
Softballdad's Avatar
Softballdad Softballdad is offline
Senior User
 
Join Date: Mar 2008
Location: Chesapeake, Va
Posts: 125
Softballdad is starting off with a positive reputation.
I thought the same thing. The last time I had it in for service they verified, and said it was the latest flash.
Reply With Quote
  #14  
Old 12-03-2011, 01:39 PM
bnmccoy's Avatar
bnmccoy bnmccoy is offline
Elder User
 
Join Date: Aug 2004
Location: Edmond, OK
Posts: 932
bnmccoy is gaining momentum as a positive member of FTE.bnmccoy is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by galaxie641 View Post
From what I have seen you will get that message if you have cut your previous regen short a few times. I've had it happen twice with the new flash and each time I knew I was cutting it short before hand.
I never cut them short; if it is in regen then I usually hit the highway (even though it seems this happens frequently after a HW trip and I'm near the house)

I always know as the fuel mileage drops; hardly ever see the short flash message. I then run through the display to confirm on status. I then reset my second trip odometer. I run anywhere from about 300 to 550 miles between regens. My exhaust tips have been black since 18K; so I suspect DPF is cracked; I will try to force the issue again at my dealer prior to 100K since the 08's are covered for that period.

You can see miles since last regen with scan tool; so I occassionaly check same too. I wish there were a regen counter too; as I have seen comments about same on the Duramax sites.

I wish they would give us the option to initiate manual regen. (while moving down the Interstate)

Bob

Last edited by bnmccoy; 12-03-2011 at 01:40 PM. Reason: clarify
Reply With Quote
  #15  
Old 12-03-2011, 10:26 PM
gwcon's Avatar
gwcon gwcon is offline
Posting Guru
 
Join Date: Jul 2008
Location: Florida
Posts: 1,053
gwcon has a great reputation on FTE.gwcon has a great reputation on FTE.gwcon has a great reputation on FTE.gwcon has a great reputation on FTE.gwcon has a great reputation on FTE.
Same thing happened to me the other day so you are not alone. Like others have said it would be nice if you could manually activate the regen if you had to cut it short a couple of times while you are on the highway.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Cleaning Exhaust Filter slinky_70 6.7L Power Stroke Diesel 18 11-12-2015 09:19 AM
Lost my "cleaning exhaust filter" message yukondiesel 6.4L Power Stroke Diesel 11 01-27-2013 06:35 PM
CEL? maltesecross 6.7L Power Stroke Diesel 4 06-08-2012 08:12 PM
"CLEANING EXHAUST FILTER" NOW STAYING ON StanleyZ 6.4L Power Stroke Diesel 31 06-09-2011 07:05 PM
Cleaning Exhaust Filter jasfaa 6.4L Power Stroke Diesel 14 01-18-2010 03:49 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2008, 2010, 64l, clean, cleaning, diesel, drive, exhaust, f250, filter, ford, ford450, light, systems, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


All times are GMT -5. The time now is 09:05 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.