Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty
Sign in using an external account
Register Forgot Password?


Super Duty & Heavy Duty 1999 to current Ford F250, F350, F450 and F550 Super Duty with diesel V8 and gas V8 and V10 engines SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 10-25-2011, 08:45 PM
fishdip fishdip is offline
New User
 
Join Date: Oct 2011
Posts: 1
fishdip is starting off with a positive reputation.
Turn Signal Problem

So I have an issue with my fuse that controls my turn signals and brake lights. It start with when turning on the left hand turn signal the fuse would blow now that I have done some work on it to find the issue when I put a fuse in it blows with out the truck running or anything.

What I have done:
  • Checked the light bulbs
  • Checked the light bulbs connectors and assemblies
  • Disconnected the Trailer assembly
  • Taken apart the steering cloumn and checked the switch assembly (this is when the problem got worse)
It is a 2004 F350
Reply With Quote
  #2 (permalink)  
Old 10-26-2011, 09:18 AM
miller_feed's Avatar
miller_feed miller_feed is offline
Hook it, I'll pull it.
 
Join Date: May 2007
Location: Grand Lake, La.
Posts: 15,009
miller_feed has a superb reputationmiller_feed has a superb reputationmiller_feed has a superb reputationmiller_feed has a superb reputationmiller_feed has a superb reputationmiller_feed has a superb reputationmiller_feed has a superb reputationmiller_feed has a superb reputationmiller_feed has a superb reputationmiller_feed has a superb reputationmiller_feed has a superb reputation
Welcome to FTE.

Sounds to me like you have a wire that is chafed and grounding out.
__________________
RICK, PAA MEMBER #4
2001, F-350, DRW. CC. LWB, 4X4, LARIAT,
MODS: 6637 W/Pete's cover, BTS-TRANS, DP-TUNER LIVE, MBRP 4" SS, Isspro 3 gauge kit, TN-BB turbo, Bellowed up pipes, HPX, TRU-COOL cooler, SS Stage II injectors, and the Chris-fifty.
Reply With Quote
Old 10-26-2011, 09:18 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Super Duty/Heavy Duty > Super Duty & Heavy Duty

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 09:20 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup