Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-24-2011, 12:23 PM
ibyers ibyers is offline
New User
 
Join Date: Oct 2011
Posts: 9
ibyers is starting off with a positive reputation.
Weird Transmission problem?

Hi Everyone,

I recently bought a 2008 Expedition EB, I'm not sure if it has the 6r75 or the 6r80.

I have a weird Transmission Problem, I did try a search but could not find anything that resembled my problem.

When I have the gear selector in "D" I don't have any issues. I don't notice any slipping or anything out of the ordinary, it cycles through gears just fine.

However, If I put the selector in "3" it is really jerky or hesitant to accelerate, It does not do this in "1" or "2", Just in third.

Doing some searching, the only thing I could find that is "some what" related is TSB 09-15-4. But I don't think this is my problem as it does not have any of the symptoms while in "D"

What really surprised me is the fact it does not have a tranny dipstick to check the fluid!!
Reply With Quote
  #2  
Old 10-24-2011, 01:17 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,008
berry1234 is gaining momentum as a positive member of FTE.
When I start off in 3 it's as if it starts off in 2nd and is really slow. It's not jerky, just feels like it's super sluggish, I kick it into D and it's fine.
__________________
1978 F250 Lariat 4x2
2008 Expedition Eddie Bauer 4x2


Reply With Quote
  #3  
Old 10-24-2011, 01:33 PM
ibyers ibyers is offline
New User
 
Join Date: Oct 2011
Posts: 9
ibyers is starting off with a positive reputation.
Thanks for the quick reply Barry!

I was wondering if it was "locked" into 3rd when I selected 3rd. Thats exactly what it feels like (like starting off in a higher gear in a manual tranny)

You put my mind at ease knowing that others do it too.
Reply With Quote
  #4  
Old 10-25-2011, 06:00 AM
chuck s chuck s is offline
Elder User
 
Join Date: Jan 2008
Location: Broadview Hts, Ohio
Posts: 512
chuck s is starting off with a positive reputation.
Yep, 3 is 3d gear, not how high the transmission will shift.

-- Chuck
Reply With Quote
Old 10-25-2011, 06:00 AM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2007, 6r75, automatic, dipstick, enthusiasts, ford, issue, navigator, problem, problems, recall, symptoms, tranny, trans, transmission, truck, weird

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 12:45 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup