Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Ford V6 > 3.0L V6
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-05-2011, 07:17 PM
miami592's Avatar
miami592 miami592 is offline
New User
 
Join Date: Jan 2006
Location: Citrus Hills, FL
Posts: 12
miami592 is starting off with a positive reputation.
01 Ranger 3.0 ffv runs rough no power

Hi all!

Have 235k miles. Started running very rough with no power.

Replaced plugs and wires. No help.

Replaced coil pack. No help.

CPS is fine. I noticed a very very slight improvement when I ran motor with wiring harness disconnected from CPS.

Any Ideas?

I've no clue where to look next.

Any and all advice is appreciated.

M592
Reply With Quote
Old 10-05-2011, 07:17 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
'04 5.4L what are these vacuum lines for? One is broke, one is crumbling jennkent5454 2004 - 2008 F150 2 09-08-2013 12:48 PM
CPS? or Something Else? mcachran 1999 - 2003 7.3L Power Stroke Diesel 9 07-28-2013 09:40 PM
Intermittent rough idle, loss of power and severe shaking poorfatkid 1999 - 2003 7.3L Power Stroke Diesel 7 07-19-2012 06:03 PM
Installed Jimmy Jammer on Tailgate Budlight592 6.7L Power Stroke Diesel 5 01-25-2012 09:25 AM
'04 F150, code P0430 jennkent5454 2004 - 2008 F150 6 12-02-2011 09:30 AM


Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > Ford V6 > 3.0L V6

Tags
01, 1996, 2000, 30, 91, 97, ford, lack, low, power, ranger, rich, rough, ruff, running, runs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump


Participate In The Forums

Create new posts and participate in discussions. It's free!

Sign Up »





All times are GMT -5. The time now is 03:06 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup