12v power outlet near Aux in not working. - Ford Truck Enthusiasts Forums



2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

12v power outlet near Aux in not working.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 08-15-2011, 08:50 PM
hjsimpson's Avatar
hjsimpson hjsimpson is offline
Senior User
Thread Starter
 
Join Date: Oct 2003
Posts: 204
hjsimpson is starting off with a positive reputation.
12v power outlet near Aux in not working.

Does anyone know if there is a fuse for the 12v power outlet located under the climate controls.

Mine is no longer working.
Reply With Quote
  #2  
Old 08-16-2011, 11:49 AM
mpm32 mpm32 is offline
New User
 
Join Date: Jan 2009
Posts: 8
mpm32 is starting off with a positive reputation.
In the engine bay there is a fuse block in front of the fan shroud.

There are fusible link fuses in there. Look for the 20A fuses, I think it's #51 or 52, maybe #10. You can see which one it is since these fuses have a window on the top.

Be prepared to pay $3.50 to $5 per fuse.

I just had to replace three of mine since a power inverter I was using blew 3 of my 4 12v power points.
Reply With Quote
  #3  
Old 08-19-2011, 12:10 AM
hjsimpson's Avatar
hjsimpson hjsimpson is offline
Senior User
Thread Starter
 
Join Date: Oct 2003
Posts: 204
hjsimpson is starting off with a positive reputation.
Quote:
Originally Posted by mpm32 View Post
In the engine bay there is a fuse block in front of the fan shroud.

There are fusible link fuses in there. Look for the 20A fuses, I think it's #51 or 52, maybe #10. You can see which one it is since these fuses have a window on the top.

Be prepared to pay $3.50 to $5 per fuse.

I just had to replace three of mine since a power inverter I was using blew 3 of my 4 12v power points.
That was it...thank you!
Reply With Quote
  #4  
Old 08-19-2011, 07:20 AM
mpm32 mpm32 is offline
New User
 
Join Date: Jan 2009
Posts: 8
mpm32 is starting off with a positive reputation.
no problem
Reply With Quote
  #5  
Old 08-19-2011, 11:39 AM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,133
berry1234 is gaining momentum as a positive member of FTE.
Quote:
Originally Posted by hjsimpson View Post
That was it...thank you!
What fuse was it if you don't mind me asking?
Reply With Quote
  #6  
Old 08-19-2011, 02:47 PM
hjsimpson's Avatar
hjsimpson hjsimpson is offline
Senior User
Thread Starter
 
Join Date: Oct 2003
Posts: 204
hjsimpson is starting off with a positive reputation.
Quote:
Originally Posted by berry1234 View Post
What fuse was it if you don't mind me asking?
Don't mind at all! It was #52.
Reply With Quote
  #7  
Old 08-19-2011, 02:59 PM
berry1234's Avatar
berry1234 berry1234 is offline
Postmaster
 
Join Date: Mar 2001
Posts: 4,133
berry1234 is gaining momentum as a positive member of FTE.
Thanks.
Reply With Quote
  #8  
Old 08-19-2011, 07:07 PM
chuck s chuck s is offline
Elder User
 
Join Date: Jan 2008
Location: Broadview Hts, Ohio
Posts: 512
chuck s is starting off with a positive reputation.
Would be great if I could put a relay & fuse there so the outlet would be dead with the ignition OFF.

-- Chuck
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
AC outlet..... Nimrod 2017 Super Duty 15 02-26-2017 10:01 PM
rear 12v outlet not working rkeith213 2009 - 2014 F150 1 08-31-2015 01:16 PM
cigarette lighter and horn problem Lewis90i6 1987 - 1996 F150 & Larger F-Series Trucks 0 11-19-2013 09:34 PM
12v outlet and Cig outlet legionx 2004 - 2008 F150 4 01-04-2010 10:28 AM
please help 1SQ 1997-2006 Expedition & Navigator 0 06-07-2004 05:20 AM


Go Back   Ford Truck Enthusiasts Forums >

Tags
2007, ciggeratte, escape, expadition, expedition, f150, ford, fuse, lighter, outlet, power, size, wont, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 03:28 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send