Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > 6.2L V8
Sign in using an external account
Register Forgot Password?


6.2L V8 Discuss the 6.2L V8

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 07-29-2011, 06:51 AM
Menghi08LT's Avatar
Menghi08LT Menghi08LT is offline
Senior User
 
Join Date: Feb 2011
Location: Waterford CT
Posts: 264
Menghi08LT is starting off with a positive reputation.
mmenghi
Truck died...

Unfortunately!

I let it sit for two days, as I've been driving my grandmother's car to get some time on it (99 Merc Sable, 35k miles). Went to start it yesterday afternoon, nothing at all. Battery completely dead.

Called the dealership, told them I could pull the battery out to have them test it. They advised me to call Ford Roadside Assistance and have them tow it from my house to the dealership (bout 6 miles). So I did, the truck showed up almost 40 minutes late. Went to the dealer, they had a rental for me. At least this time it's a Mazda, not some Dodge junk they gave me last time.

They told me it could be just the battery, which I have no issues with. But it could also be the alternator, which is the exact reason why I sold my '08 F150 back. That was on its third by 33,000 miles. Or something else we don't know about, they had to rollback it in to look at a dead truck.

This is trip number four for this truck to the dealership in five months. Needless to say, as much as I love the truck, I'm tired of having issues with it. Should it be something greater than the battery, I'm going to push for buyback. CT's lemon law states four reasonable attempts at repairing it, which this is what it would be...
__________________
Matt

2011 F250 XL Regular Cab
5-Star SCT Tuned 6.2L; Airaid Intake; Rear muffler delete; 33x10.5 BFG KM2's on 17" XD Cranks; Pioneer DVD system with Kicker Comp CVR; OEM Foglight mod, Fisher 8ft HD Plow
Reply With Quote
  #2 (permalink)  
Old 07-29-2011, 09:47 AM
kmonty2's Avatar
kmonty2 kmonty2 is offline
Posting Guru
 
Join Date: Dec 2010
Location: Sterling Heights, MI
Posts: 1,310
kmonty2 is gaining momentum as a positive member of FTE.kmonty2 is gaining momentum as a positive member of FTE.
kmonty
Didn't you have it in for the transmission before? If so have you had any problems since the last flash? Hopefully it's just the battery, but I have left my interior lights on all night and came out and it started up just as it did every other day. I didn't even notice the lights were on until I got out at work and saw they weren't shutting off.
__________________


Kevin
2011 F-250 CC, 6.2 Gas, 3.73, 4x4 w/FX4, Tuxedo Black, Steel Cloth interior,Goodyear Wrangler Duratrac's, Air Aid Intake, Bilstein 5100 shocks, Hellwig adjustable sway bar, 5 Star Tuned, Line X bed liner, X Tang Tri-Fold bed cover.
Reply With Quote
  #3 (permalink)  
Old 07-29-2011, 10:02 AM
Menghi08LT's Avatar
Menghi08LT Menghi08LT is offline
Senior User
 
Join Date: Feb 2011
Location: Waterford CT
Posts: 264
Menghi08LT is starting off with a positive reputation.
mmenghi
I haven't had any other issues, the TPMS light still was going off periodically but that's it. I still haven't heard from the dealer, I got a picture message from a rather sarcastic friend of mine who works at Carquest, he delivered a part and saw my truck outside still at around 9:45am. It's just after 11 now and still no call.
__________________
Matt

2011 F250 XL Regular Cab
5-Star SCT Tuned 6.2L; Airaid Intake; Rear muffler delete; 33x10.5 BFG KM2's on 17" XD Cranks; Pioneer DVD system with Kicker Comp CVR; OEM Foglight mod, Fisher 8ft HD Plow
Reply With Quote
  #4 (permalink)  
Old 07-29-2011, 10:19 AM
kmonty2's Avatar
kmonty2 kmonty2 is offline
Posting Guru
 
Join Date: Dec 2010
Location: Sterling Heights, MI
Posts: 1,310
kmonty2 is gaining momentum as a positive member of FTE.kmonty2 is gaining momentum as a positive member of FTE.
kmonty
Well it sounds like they are in no hurry to fix your truck.
__________________


Kevin
2011 F-250 CC, 6.2 Gas, 3.73, 4x4 w/FX4, Tuxedo Black, Steel Cloth interior,Goodyear Wrangler Duratrac's, Air Aid Intake, Bilstein 5100 shocks, Hellwig adjustable sway bar, 5 Star Tuned, Line X bed liner, X Tang Tri-Fold bed cover.
Reply With Quote
  #5 (permalink)  
Old 07-29-2011, 12:29 PM
Menghi08LT's Avatar
Menghi08LT Menghi08LT is offline
Senior User
 
Join Date: Feb 2011
Location: Waterford CT
Posts: 264
Menghi08LT is starting off with a positive reputation.
mmenghi
Just called them, apparently its in the shop, waiting on a call back...
Reply With Quote
  #6 (permalink)  
Old 07-29-2011, 07:50 PM
Menghi08LT's Avatar
Menghi08LT Menghi08LT is offline
Senior User
 
Join Date: Feb 2011
Location: Waterford CT
Posts: 264
Menghi08LT is starting off with a positive reputation.
mmenghi
Alright well I got it back tonight, it was just a shorted cell in the battery. Kinda sad that it was a life of five months... I'll keep this updated if theres an underlying problem that didn't come up on diagnosis. The service manager and I joked around about it, saying that the truck was "as dead as he's ever seen". I did state that I'm unhappy to a couple of people within the dealership that I know, both service and salesman, I'm assuming they figured out that if the next visit isn't for service it's for a new truck.

One note I should have posted earlier was that I went by that way at around 8am, which was about an hour after they open. They had moved the truck, got a picture message from a friend of mine and it was still in the same spot. It was also there when I picked it up tonight, same spot. Another side note is that this is it's third trip since 6/21.
__________________
Matt

2011 F250 XL Regular Cab
5-Star SCT Tuned 6.2L; Airaid Intake; Rear muffler delete; 33x10.5 BFG KM2's on 17" XD Cranks; Pioneer DVD system with Kicker Comp CVR; OEM Foglight mod, Fisher 8ft HD Plow
Reply With Quote
  #7 (permalink)  
Old 07-29-2011, 10:53 PM
kmonty2's Avatar
kmonty2 kmonty2 is offline
Posting Guru
 
Join Date: Dec 2010
Location: Sterling Heights, MI
Posts: 1,310
kmonty2 is gaining momentum as a positive member of FTE.kmonty2 is gaining momentum as a positive member of FTE.
kmonty
Well that is good news, just a bad battery. At least it was something Ford had nothing to do with. They just buy battery's from the lowest bidder and install them.
__________________


Kevin
2011 F-250 CC, 6.2 Gas, 3.73, 4x4 w/FX4, Tuxedo Black, Steel Cloth interior,Goodyear Wrangler Duratrac's, Air Aid Intake, Bilstein 5100 shocks, Hellwig adjustable sway bar, 5 Star Tuned, Line X bed liner, X Tang Tri-Fold bed cover.
Reply With Quote
  #8 (permalink)  
Old 07-30-2011, 05:52 AM
nycsteve nycsteve is offline
Senior User
 
Join Date: Jan 2009
Location: Long Island, NY
Posts: 178
nycsteve is starting off with a positive reputation.
I also had my battery replaced after less than 5 monthes. This was after the dealership telling me it was normal for the truck to go dead in the driveway in 10 days if not used , in cold weather. When they finally checked it the little green light was not green but red. New battery, no problems.
Reply With Quote
  #9 (permalink)  
Old 07-31-2011, 07:01 PM
Menghi08LT's Avatar
Menghi08LT Menghi08LT is offline
Senior User
 
Join Date: Feb 2011
Location: Waterford CT
Posts: 264
Menghi08LT is starting off with a positive reputation.
mmenghi
I can see normal after an extended period of time, but two days? Not even two full days, it sat from the evening the first night until mid day the second day. On the contrary to this, my grandmother's '99 Merc Sable sat over thirty days unused and still started right up last year, original battery and all.

Aside from this, my TPMS light that I've posted about on here came on again. Still unresolved. I'm pretty pissed at both the truck and dealer right now...
__________________
Matt

2011 F250 XL Regular Cab
5-Star SCT Tuned 6.2L; Airaid Intake; Rear muffler delete; 33x10.5 BFG KM2's on 17" XD Cranks; Pioneer DVD system with Kicker Comp CVR; OEM Foglight mod, Fisher 8ft HD Plow
Reply With Quote
Old 07-31-2011, 07:01 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Performance, Engines & Troubleshooting > 6.2L V8

Tags
1972, 1973, 304, alternator, commando, dead, died, fell, ford, jeep, king, matthew, muffler, piece, truck

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 01:17 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup