Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007+ Expedition & Navigator 2007, 2008, 2009 and 2010 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 07-17-2011, 12:22 AM
89foxGT 89foxGT is offline
Freshman User
 
Join Date: May 2008
Posts: 26
89foxGT is starting off with a positive reputation.
how to wire in aftermarlet amp '09 expedition

how would I wire in an aftermarket amp to my 09 expedition limited max, I want to run the jl stealthbox and I'm pretty sure it isn't amplified. I have the stock nav head unit, I would really like to retain the stock look.

thanks
Reply With Quote
  #2 (permalink)  
Old 07-17-2011, 03:12 PM
SickPup404 SickPup404 is offline
Junior User
 
Join Date: Mar 2011
Posts: 63
SickPup404 is starting off with a positive reputation.
Just off the top of my head, I'd check with Crutchfield - they usually have adapting harnesses for just about everything.
__________________
Steve
2007 Expedition EL Limited
Reply With Quote
Old 07-17-2011, 03:12 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007+ Expedition & Navigator

Tags
2008, amp, expedition, expedtion, forum, power, running, wire, wiring

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 03:23 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup