V10 running rough?? - Page 2 - Ford Truck Enthusiasts Forums



Excursion - King of SUVs 2000 - 2005 Ford Excursion
Sponsored by:
Sponsored by:

V10 running rough??

Reply
 
 
 
Thread Tools Search this Thread
  #16  
Old 06-03-2014, 05:00 AM
wpnaes's Avatar
wpnaes wpnaes is offline
FTE SoCal Chapter LDR
 
Join Date: Nov 2010
Location: So Cal
Posts: 9,870
wpnaes has a superb reputationwpnaes has a superb reputationwpnaes has a superb reputationwpnaes has a superb reputationwpnaes has a superb reputationwpnaes has a superb reputationwpnaes has a superb reputationwpnaes has a superb reputationwpnaes has a superb reputationwpnaes has a superb reputationwpnaes has a superb reputation
Sounds like snake oil - save your $.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Missing injectors, could be FICM johnl2 6.0L Power Stroke Diesel 74 03-12-2017 10:26 PM
Intermittent (but repeatable) miss, 09 Escape ustabe Escape & Escape Hybrid 6 04-11-2016 06:56 AM
1985 F150 300I6 loud pop, now has bad miss Bagbyknoter Ford Inline Six, 200, 250, 4.9L / 300 3 11-10-2014 06:45 PM
2000 6.8 limited 2wd random miss in motor Combatmedic2010 Excursion - King of SUVs 20 06-04-2013 06:51 PM
Running Rough bnuvp Excursion - King of SUVs 9 11-28-2008 01:53 PM


Go Back   Ford Truck Enthusiasts Forums >

Tags
1500, 2001, 2005, codes, engien, excursion, exhaust, f450, ford, miss, rough, rpm, run, runs, v10

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 08:07 AM.