Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator
Sign in using an external account
Register Forgot Password?


2007 - 2014 Expedition & Navigator 2007, 2008, 2009, 2010, 2011, 2012, 2013 and 2014 Ford Expedition and Lincoln Navigator

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-11-2011, 09:02 AM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 227
jdm5630 is starting off with a positive reputation.
expy feels loose while driving

i was driving down the highway today and the drive feels really loose i have to really keep a tight grip on the wheel epecially wehen i pass a semi. Is this normal?
Reply With Quote
  #2  
Old 06-11-2011, 09:11 AM
glruff's Avatar
glruff glruff is offline
Super Moderator
 
Join Date: Aug 2006
Location: DELAWARE, The First State
Posts: 44,523
glruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputation
Can you tell us a little more about you expy?

Year, model, etc.
__________________
George, FTE Chapters Moderator
Reply With Quote
  #3  
Old 06-11-2011, 09:12 AM
chuck s chuck s is offline
Elder User
 
Join Date: Jan 2008
Location: Broadview Hts, Ohio
Posts: 512
chuck s is starting off with a positive reputation.
Not experienced this with mine. What tire pressure are you running? I run 35psi as indicated on the placard in the door jam.

-- Chuck
Reply With Quote
  #4  
Old 06-12-2011, 09:29 AM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 227
jdm5630 is starting off with a positive reputation.
it is a 2007 EL . i am running 356 psi on mine also
Reply With Quote
  #5  
Old 06-12-2011, 10:04 AM
glruff's Avatar
glruff glruff is offline
Super Moderator
 
Join Date: Aug 2006
Location: DELAWARE, The First State
Posts: 44,523
glruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputationglruff has a superb reputation
Running the same 35psi on 20" Pirelli Scorpions with no issues.

Just the annoying tire thump until the tires warm up.
__________________
George, FTE Chapters Moderator
Reply With Quote
  #6  
Old 06-12-2011, 01:03 PM
jdm5630 jdm5630 is offline
Senior User
 
Join Date: Nov 2006
Location: Odessa
Posts: 227
jdm5630 is starting off with a positive reputation.
maybe its just me. its always windy where i live. But i dont experience these problems in my 06 F250
Reply With Quote
Old 06-12-2011, 01:03 PM
 
 
 
Reply

Go Back   Ford Truck Enthusiasts Forums > Newer Light Duty Trucks > 2007 - 2014 Expedition & Navigator

Tags
driving, loose, navigator

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



All times are GMT -5. The time now is 01:36 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup