Go Back   Ford Truck Enthusiasts Forums > Bronco > 1978 - 1996 Big Bronco
Sign in using an external account
Register Forgot Password?


1978 - 1996 Big Bronco SPONSORED BY:

Welcome to Ford-Trucks Forums!
Welcome to Ford-Trucks.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Ford-Trucks Forums community today!





 
Reply
 
LinkBack Thread Tools Search this Thread
  #1 (permalink)  
Old 06-01-2011, 02:35 PM
garydmundy garydmundy is offline
Senior User
 
Join Date: Aug 2009
Location: Banner WY Pop 42, yes 42
Posts: 125
garydmundy is gaining momentum as a positive member of FTE.garydmundy is gaining momentum as a positive member of FTE.
Clutch not fully engaging properly?

1994 Bronco aftermarket 351 with Mazda 5 speed and hydraulic clutch. Recently the clutch does not seem to completely engage when the clutch is pressed to the floor. It is very hard to get into first gear (sometimes I can't even get it into 1st), slight grinding when upshifting in all gears and real grinding when shifting into reverse. This has come on gradually. I have checked the fluid level in the master cylinder and it was low but now out. I filled it but no improvement. The other thing the clutch pedal sometime won't come all the way back and I have to use my foot to pull it back to its resting position. Any suggestions?
Reply With Quote
  #2 (permalink)  
Old 06-01-2011, 02:44 PM
Kemicalburns's Avatar
Kemicalburns Kemicalburns is offline
Post Fiend
 
Join Date: Jul 2002
Location: OregonCity,OR
Posts: 13,294
Kemicalburns has a very good reputation on FTE.Kemicalburns has a very good reputation on FTE.Kemicalburns has a very good reputation on FTE.Kemicalburns has a very good reputation on FTE.
sounds like the slave cylinder is bad or you have air in the line and it needs bleed.
__________________
94 XLT 357/E4OD/Warn HS9500I
6"ProComp Stage II 35x12.5x15 BFG AT's
4.88 gears/Aussie Front/rear open
Edelbrock efi intake JBA shorty,CustomY pipe/exhaust
http://www.supermotors.org/registry/...il.php?id=4158
Reply With Quote
Old 06-01-2011, 02:44 PM
Reply

Go Back   Ford Truck Enthusiasts Forums > Bronco > 1978 - 1996 Big Bronco

Tags
1994, 2000, 86, 95, ac, bronco, clutch, engaging, f150, f250, ford, fully, hydraulic, ii, properly

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump



All times are GMT -5. The time now is 12:16 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.
Advertising - Terms of Use - Privacy Statement - Jobs
This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company.

vbulletin Admin Backup